Honda Pilot - Honda Pilot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So I started the Pilot this afternoon and heard a buzzing from the engine compartment. I popped the hood to find a rubber hose being grinded down by the radiator fans. It was not connected to anything.

After removing the engine cover and exhaustively searching for its home, I can't seem to find where this hose comes from. Vehicle runs fine, no codes or engine light. Temperature looks good after 20 miles on the Autobahn.

What is it? I'm beginning to think that I picked up a random hose from the road. Thank you in advance for any advice!

20190610_185905.jpg
 

·
Administrator
Joined
·
15,521 Posts
If there is no coolant leak, no oil leak, no transmission leak, and your AC works, you just picked up some debris.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Everything seems in order. I take a lot of pride in maintaining my Pilot. Every little out-of-place sound and I become a little obsessed.

This appeared to be devastating, but another search revealed nothing. Your comment just gives me a warm fuzzy that it's just random debris. I'll keep my eyes peeled but wow, how in the world did it end up there?!
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
2,957 Posts
If the hose has a part number etched into it you could search to see if it’s from a Honda Pilot.
 

·
Registered
Joined
·
50 Posts
That's pretty substantial- if it is actually from the Pilot I think you'd know it by now. Interesting-where in the engine compartment did you find it? Jammed up in the bottom part?
 
1 - 5 of 5 Posts
Top