Honda Pilot - Honda Pilot Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2012 Honda Pilot EX N recently I started hearing a weird clanking metal noise on the front drivers side happens when I go over lol bumps on the road almost sounds as if something is loose. Went to a mechanic shop n they checked out the sway bar link n he said it was good .the whole front suspension was recently replaced minus the front shocks. Utube has been saying it might b the front sway bar link the mechanic said it looks n feels good. Another mechanic I took it to sahs he thinks it's the muffler that's loose but he checked n it's good. I'd love to figure out this noise so that I can fix it sounds like something is loose n hitting metal on metal when I go on the road .I'm worried to drive it on the highway for fear that something might break off n stuff .any help would b very appreciated .thanks in advance
 

·
Registered
Joined
·
11,439 Posts
I have a 2012 Honda Pilot EX N recently I started hearing a weird clanking metal noise on the front drivers side happens when I go over lol bumps on the road almost sounds as if something is loose. Went to a mechanic shop n they checked out the sway bar link n he said it was good .the whole front suspension was recently replaced minus the front shocks. Utube has been saying it might b the front sway bar link the mechanic said it looks n feels good. Another mechanic I took it to sahs he thinks it's the muffler that's loose but he checked n it's good. I'd love to figure out this noise so that I can fix it sounds like something is loose n hitting metal on metal when I go on the road .I'm worried to drive it on the highway for fear that something might break off n stuff .any help would b very appreciated .thanks in advance
Old worn out struts are the likely cause.
 

·
Registered
Joined
·
20 Posts
I don't know if it helps, but I am going through the same thing with my '13 right now. I believe it is the sway bar end links. the movement is minimal but once I found it, it was clearly the culprit. I had to jack up the entire front end of the car and check the end joint thoroughly. A quick wiggle didn't get the job done.
Currently, I am trying to decide if I am going to stay with the stock design or get one with the grease fittings.
 
1 - 8 of 8 Posts
Top