Honda Pilot - Honda Pilot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I started my 2010 Pilot EX-L this morning for a second time and the VTM, VSA and Check Engine lights all came on. I drove about a quarter mile and turned it off and sat for about 2 minutes. When I started it back up only the check engine light stayed on. I drove it about 25 miles to work and the light stayed on the whole time. Not sure what I should do. Any insight would be greatly appreciated.
 

·
Registered
Joined
·
216 Posts
Go get the codes pulled to find out what's going on. Head to the nearest autozone, OReillys, ect.

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
216 Posts
Pull the #4 spark plug and take a look. More than likely fouled. How many miles do you have on them?

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
133 Posts
If your spark plug is fouled more than likely your piston rings are bad.


Check to see if there is a warranty extension for your piston rings.

I have replaced piston rings on Pilots that had over 100,000 miles because the warranty states 8 years unlimited miles from original purchase date
 

·
Registered
Joined
·
1 Posts
This just happened to me as well on my 2011 Honda pilot EX-L. I got the codes an they were PO-306 misfire and random misfire the auto zone guy said it was the camshaft positioning sensor. Does this sound right? I am also wondering were this is located on the engine?
 
1 - 7 of 7 Posts
Top