Honda Pilot - Honda Pilot Forums banner
1 - 8 of 8 Posts

·
Registered
2008 Piot SE FWD, 2015 Pilot LX 4WD. 2005 GSX-R1000
Joined
·
2,188 Posts
Hi Amy,
I also have a Gen 1, but haven't experienced this.
So no power to the fans, etc. also?

I'd check you furse box for the fuse that runs this system for starters.
Hopefully it's something that simple. Don't know why the temp wouldn't show either.
Some one will chime in
 
  • Like
Reactions: aggrex

·
Registered
Joined
·
312 Posts
I agree with The Todd. I would check the fuses first. And would also like to know if the fan etc works but the display does not. I am leaning towards a fuse. There will be several for the AC system.

Does everything else work on the car? Parking lights, interior lights, etc
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Yes I have cold air just blowing even when it's not on. When it was working the blend door armature went out and I couldn't get it out so I messed with it until cold air blew ( this was at beginning of summer) so now I need to manually mess with it until I get hot air again but just recently this went out.
 

·
Registered
2008 Piot SE FWD, 2015 Pilot LX 4WD. 2005 GSX-R1000
Joined
·
2,188 Posts
Well, glad it was an easy fix so far. Good luck with the blend door?
 

·
Registered
Nobili spiritus embiggens pequeño sparus tyre.
Joined
·
10,290 Posts
Glad you found it. (y) For the record, which fuse did it turn out to be? (See attachment.)
 

Attachments

·
Registered
Joined
·
9,775 Posts
Do we know why the fuse blew?
If not, is it likely for a new fuse to also blow unless the underlying problem is found and corrected?
 
1 - 8 of 8 Posts
Top