Honda Pilot - Honda Pilot Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,573 Posts
Discussion Starter · #1 ·
Found a supercharger at the local bone yard ..thought nothing of it since I was not sure about it..then again I didn't think there was one for the J35 series engine.
It was in a 08 Honda pilot I left it there .. I found a pic online with the exact same setup so yes they do exist..

133241
 

·
Registered
Joined
·
35 Posts
Found a supercharger at the local bone yard ..thought nothing of it since I was not sure about it..then again I didn't think there was one for the J35 series engine.
It was in a 08 Honda pilot I left it there .. I found a pic online with the exact same setup so yes they do exist..

View attachment 133241
I wonder if it still works? You going back for it?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4,264 Posts
You should definitely go get it!

What's the brand, any idea? I think Stillen maybe offerred a kit for the J35 at one point? I don't think there was ever a factory backed option like TRD was doing for the 4.0 V6 and 5.7 V8.
 

·
Registered
Joined
·
2,573 Posts
Discussion Starter · #4 · (Edited)
Going back this weekend to see what they want for it.. may just buy the whole pilot or what's left since Im sure it's tuned to be able to run that sucker..
 

·
Registered
Joined
·
4,264 Posts
Nice!

Your sig keeps making me reminiscent of my '01 Pathfinder... VQ35, 5 speed manual, 4WD, rear diff out of a Frontier Desert Runner so it was an extremely tight LSD... man I miss that thing and regret getting rid of it.
 

·
Registered
Joined
·
2,573 Posts
Discussion Starter · #6 ·
The Pathy was a real 4wd ..that thing went through everything and came out with flying colors !.. I gave her up for the 2015 pilot...nasty mistake should have never been done.
 

·
Registered
Joined
·
1,653 Posts
What's up with the screws missing from the valve cover? Are they for a harness not used on the SC engine?
 

·
Registered
Joined
·
2,573 Posts
Discussion Starter · #8 ·
not only that the steering pump is missing from the block and belt is straight running to the charger
 
1 - 8 of 8 Posts
Top