Honda Pilot - Honda Pilot Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I bought an 04 with high miles on it, but I like Honda so I didn’t care much about that. drove it for half a day and about 3 in the afternoon I had an appointment for about 15 minutes. Tried to start it and all it would do was crank but not start. Towed it to the dealer. They “tested” and found the battery to have a bad cell etc. And replaced it. I questioned it a bit but it is what it is. So i drove home. Halfway it stalled while driving. Coates to a safe spot and called my mechanic friend. He asked if the pump was priming with the key. It wasn’t. I tapped the gas tank with a mallet. (More or less whacked it because it made me feel better) first try no prime. Second time it primed and started. So I went to the fuel pump. Got a used one and replaced it to see what happened. Started up and ran almost until I got to work. Stalled on the highway. Started after a few minutes of sitting. It stalled on the way home and after an hour an a half I towed it home. It wasn’t priming the fuel pump. So I replaced (PGM-FI#2) the main relay and it primes every time now. But it still quit on me the next day. Wouldn’t start up. After 10 Minutes or so it did and I made it back to work. Once there I went to leave and it would crank and start for 1 second then die. It did that over and over. I left it for the night then took it to the dealer to pay them specifically to chase this issue for a couple of hours. They couldn’t get it to quit even after running it outside for a while. And since then it hasn’t quit at all. I can’t trust it to do anything useful so I’m at a loss of where to look next. I’m not a mechanic, I have a basic understanding but I’m not awesome. I’m willing to entertain any possibilities that may be floating around in this group.
 

·
Registered
2008 Honda Pilot EX-L
Joined
·
314 Posts
I'd say try putting your original fuel pump back in since it sounds like it was the relay causing your issues from the beginning.

Otherise hows your intake tube look? Cracked/leaking by chance?
 

·
Registered
Nobili spiritus embiggens pequeño sparus tyre.
Joined
·
9,265 Posts
Otherise hows your intake tube look? Cracked/leaking by chance?
As often gets posted, here are some examples of what to look for. Pay special attention however, to what isn't immediately easy to see: the underside of the air intake tube and right nest to the hose clamps at either extremity.

146205


146206


While it's certainly worth checking, I'm not entirely convinced that's your problem. If it is, you got lucky with an easy fix.
 

·
Registered
Joined
·
19 Posts
Chck fuel prssre, flow and hold the pressure when you shut it off?. check wiring harness. does the green key light on?
Check battery cable is not rusted
 

·
Registered
2008 Piot SE FWD, 2015 Pilot LX 4WD. 2005 GSX-R1000
Joined
·
2,063 Posts
I'd say try putting your original fuel pump back in since it sounds like it was the relay causing your issues from the beginning.

Otherise hows your intake tube look? Cracked/leaking by chance?
on my 08- 191K miles;
My intake tube was off of my throttle body for months, yes, it was sucking up to 1/2 it's air from there, not down the tube.

It ran the same. Why do people think it won't run with a even a crack in it?
 

·
Registered
2008 Piot SE FWD, 2015 Pilot LX 4WD. 2005 GSX-R1000
Joined
·
2,063 Posts
View attachment 146206

While it's certainly worth checking, I'm not entirely convince that's your problem. If it is, you got lucky with an easy fix.
This picture looks like my 08's tube- except mine is all the way off- separated.
I push it on the TB and it stays for a few days and comes off again. I never know it's off because:

IT RAN THE SAME.

I guess that this actually makes some of them run poorly?

It would NOT keep it from starting IMHO.

Rant over.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
I'd say try putting your original fuel pump back in since it sounds like it was the relay causing your issues from the beginning.

Otherise hows your intake tube look? Cracked/leaking by chance?
So I did this. I put in my new relay and still had problems. I got annoyed and took out the fuel pump replaced it with the original one I had found in there and it’s running fine. 600 miles and no problems. I do notice it takes a couple of second to start when I turn it over but I’m going to pull the plugs and replace them to see if that solves it. Thanks for the idea it worked
 

·
Registered
Nobili spiritus embiggens pequeño sparus tyre.
Joined
·
9,265 Posts
This picture looks like my 08's tube- except mine is all the way off- separated.
I push it on the TB and it stays for a few days and comes off again. I never know it's off because:

IT RAN THE SAME.

I guess that this actually makes some of them run poorly?

It would NOT keep it from starting IMHO.

Rant over.
[JOKE]

You must have very clean air where you live. :p

[/JOKEOVER]
 

·
Administrator
2016 CRV Touring AWD, 2005 Pilot RIP.
Joined
·
16,042 Posts
Keep a good amount of gas in it. Less chance of gunk being sucked into the pump and restricting the fuel flow. As it’s running good right now, leave it be.
 

·
Registered
2008 Honda Pilot EX-L
Joined
·
314 Posts
So I did this. I put in my new relay and still had problems. I got annoyed and took out the fuel pump replaced it with the original one I had found in there and it’s running fine. 600 miles and no problems. I do notice it takes a couple of second to start when I turn it over but I’m going to pull the plugs and replace them to see if that solves it. Thanks for the idea it worked
Glad to hear that things are better with the old fuel pump, and new relay 👏

In regards to the slow starts, do you give the fuel pump enough time to prime before you start cranking it over? E.g. when you first climb into your vehicle, try putting the key to "on" but not start, and then put your seatbelt on, (you should hear the fuel pump "hum" for a few seconds while doing so), then after you're buckled in, turn the key to Start the vehicle and see if it still takes as long as start?
 
1 - 14 of 14 Posts
Top