Honda Pilot - Honda Pilot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Has anyone had problems with the 'skip+' button on the stereo collapsing? I had this problem and the dealer replaced the stereo. Now it has also happened with the replacement. If its a common problem I'll probably just put up with it. It still works fine, it just looks bad. The button looks permanently depressed on the passenger side.
 

·
Registered
Joined
·
7,953 Posts
mine is fine I think...let me check ..wait...

(goes to the garage to check ).....

yes its fine....
 

·
Registered
Joined
·
1,117 Posts
Fraj said:
Has anyone had problems with the 'skip+' button on the stereo collapsing? I had this problem and the dealer replaced the stereo. Now it has also happened with the replacement. If its a common problem I'll probably just put up with it. It still works fine, it just looks bad. The button looks permanently depressed on the passenger side.
I had the same problem last November. Click here. After they replaced my Head Unit, mine has been fine.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Right, mines on the other side, but it looks just like your picture. Guess I'll get them to replace it again. Last time they scraped the plastic on the vents just below the stereo during the replacement, so I'll have to decide whether or not to take the risK!
 

·
Registered
Joined
·
95 Posts
I have the same problem with my skip button. It started almost right after I got the Pilot. It has always annoyed me.

I am glad this thread came up again. I had no idea I could get the whole unit replaced for this.
 
1 - 7 of 7 Posts
Top