Honda Pilot - Honda Pilot Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My 2010 Pilot was running like a dream at 105,000 then I had the timing belt replaced because of the service minder code said it was time. I had the service done at the Honda dealer. Six weeks out and now I regret it. The engine has a rough idle and I have also noticed that there is a sputtering sound coming from the rear exhaust. No check engine or code indicators have appeared...will an engine tune up correct this?
 

·
Registered
Joined
·
36 Posts
Did the rough idle start immediately after service?
Might consider having a local shop read computer...I have had codes sit in system for high idle while the check engine light was not seen. Ended up replacing throttle body
Reset the computer....see if it settles out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Did the rough idle start immediately after service?
Might consider having a local shop read computer...I have had codes sit in system for high idle while the check engine light was not seen. Ended up replacing throttle body
Reset the computer....see if it settles out.
My brother in law has the diagnostic computer. Will an issue show up just by putting it on the computer even if the are no code indicators? I considered asking him but I hate to bother him...he is mechanic for UA and only home a few days every other week.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
My brother in law has the diagnostic computer. Will an issue show up just by putting it on the computer even if the are no code indicators? I considered asking him but I hate to bother him...he is mechanic for UA and only home a few days every other week.
The rough idle started within a week of service and has gotten worse.
 
1 - 4 of 4 Posts
Top