Honda Pilot - Honda Pilot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Has anyone else had trouble with the electronics on your Honda Pilot? Six weeks ago, I started my 2017 Pilot Touring and all sorts of lights came on. I kept getting one error message after another: Hill Start Assist Problem, Power Steering Problem,Trailer Stability Assist Problem, Road Departure Mitigation Problem, Emissions System Problem and Transmission System Problem. I was able to drive my Pilot to the dealer and the electronic codes did not seem to affect the drive. The dealer could not find a reason for all the codes so they did a system reset and things were fine until today. I started my car this morning and I got the same rolling codes and lights on the dash. This time however, when I started to drive, I could tell the transmission was not working correctly and suddenly the car put itself into Standard Mode. The car wouldn't shift into a higher gear. I pulled over and had it towed to the dealer and I'm still waiting for a response from them. I'd like to know if anyone else has had similar issues.
 

·
Registered
Joined
·
3 Posts
My wife’s 2016 touring just did this today for the first time. Driving seemed to be without any issues, but the same rolling codes. Did you ever figure out what this was about?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
The service department tells me my Pilot needs new fuel injectors. They say it is a known problem and there’s a service bulletin out on it. Thankfully it is covered under my extended warranty. Hopefully this puts an end to the problem.
 

·
Registered
Joined
·
2 Posts
I just had these pop up on our Pilot with the exact same thing. My mechanic reset the codes and recommended hooking the battery up to a charger. When I got home the charger was reading low so something is wrong with the charging system or my battery, but according to my mechanic, these codes are all related to an electrical surge or shortage of the correct voltage. I will let you know if this comes back with a full battery.
 

·
Registered
Joined
·
2 Posts
Had the codes pop up once again, resetting them fixed everything, but this isn't a good 'fix'. My battery reads 12.68 volts after sitting overnight, and 14.27 when idling, so I believe the battery and charging system are good. Back to the drawing board. Might be related, but this seems to come up more often when the vehicle is quarter tank or lower of fuel.
 
1 - 6 of 6 Posts
Top