Honda Pilot - Honda Pilot Forums banner

1 - 20 of 96 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
So been hearing a little noise that comes and goes for a little while now (After my alignment on the 11th) LOOKS like back tire was wobbling And SOUNDS like back tire was being ripped or rubbing against something (Pic 1) Thought maybe it was the weather proof shield thing around the tire cutout space. So I jacked the car and saw (Picture2) Now I had an alignment (front + back) done on the 11th. Could the alignment shop had caused this? That’s probably where the burning smell was coming from too...which started after I got the alignment. Anyone knows??
 

Attachments

·
Registered
Joined
·
99 Posts
Discussion Starter #2
Not sure if it’s normal to have play but when it moves the tires back and forth the “proper way” (While the wheel is off the ground they move. The backs move ever so slightly, while the front to have much more play. THE BACK RIGHT TIRE MAKES A SQUEAKING SOOUND WHEN I DO SO.
And even though the brake lights flicker on and off once in a blue moon (And I mean flicker. Never fully stay on long enough for me to read what it says but I know what’s being lit up) I never hear the brake indicator go off when I’m braking (you know...the screech).
Could the breaks be the reason?
 

·
Registered
Joined
·
2,969 Posts
So been hearing a little noise that comes and goes for a little while now (After my alignment on the 11th) LOOKS like back tire was wobbling And SOUNDS like back tire was being ripped or rubbing against something (Pic 1) Thought maybe it was the weather proof shield thing around the tire cutout space. So I jacked the car and saw (Picture2) Now I had an alignment (front + back) done on the 11th. Could the alignment shop had caused this? That’s probably where the burning smell was coming from too...which started after I got the alignment. Anyone knows??
Not normal. Something has come loose. Yes, it could be as a result from the alignment. I wouldn't drive it like that. Send them your photos/call their shop.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #4
Not normal. Something has come loose. Yes, it could be as a result from the alignment. I wouldn't drive it like that. Send them your photos/call their shop.
I’m literally like 10 minutes away from home by highway. I thought something was off but couldn’t figure out what. That same exact piece is sticking out on the other side as well
 

·
Registered
Joined
·
1,100 Posts
If the end link is broken or missing get something to secure the end of the sway bar. If the bolt or broken parts of the end link continue to rub then you’ll have a tire problem. May have to tie up both sides if the other side is also broken. Those broken parts could also damage brake lines and cv boots etc. I’d say you’re quite lucky so far.
 

·
Registered
Joined
·
1,100 Posts
Post a picture of the other side of the sway bar and another picture upwards to the right of the spring as I’m curious about the frame. Be careful as that scissor jack doesn’t look safe and secure.
 

·
Registered
Joined
·
35 Posts
Your rear sway bar is actually rubbing on your CV Axle(check the shiny part).

Since your missing a link your sway bar will come in contact with the cv axle when you make a turn, hit the right road bumps and if your rear is bouncing.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #10
Post a picture of the other side of the sway bar and another picture upwards to the right of the spring as I’m curious about the frame. Be careful as that scissor jack doesn’t look safe and secure.
Still don’t know what angle your looking for. But yeah that jack is rusted and all
 

·
Registered
Joined
·
99 Posts
Discussion Starter #11
Your rear sway bar is actually rubbing on your CV Axle(check the shiny part).

Since your missing a link your sway bar will come in contact with the cv axle when you make a turn, hit the right road bumps and if your rear is bouncing.
All dusty under there
 

·
Registered
Joined
·
99 Posts
Discussion Starter #12
Your rear sway bar is actually rubbing on your CV Axle(check the shiny part).

Since your missing a link your sway bar will come in contact with the cv axle when you make a turn, hit the right road bumps and if your rear is bouncing.
So after watching a sway bar replacement video and reading this comment I just realized I DONT HAVE A SWAY BAR LINK!!! Does that mean it fell off while I was driving? Did the alignment shop remove it??!! Because how am I missing both???
AND IM PRETTY SURE NOW THATS WHERE THE BURNING SMELL IS COMING FROM.
I JUST MOVED THAT PIECE WITH MY HAND🤯!! Is that piece suppose to move???!!!
 

·
Registered
Joined
·
35 Posts
These two areas have been making contact.
64E6F4E8-B2C4-4CC7-A294-63B4E924D93E.jpeg

Your sway bar link has been missing for sometime, judging from all the rust.
It's possible that it broke from one end and whatever remained probably got taken off from suspension movement.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #18
$2k? look likes it just needs a new sway bar link...they cost under $30 for like a pair.
Was told by a shop my whole suspension needs work, loose steering and all. Plus engine might a bad catalytic converter . Needs tune up. Never changed transmission fluid for like a year (when I bought it) car skips and hesitates when I slow down then accelerate (might be spark plugs or something else🤷🏾)
 

·
Registered
Joined
·
1,100 Posts
Was told by a shop my whole suspension needs work, loose steering and all. Plus engine might a bad catalytic converter . Needs tune up. Never changed transmission fluid for like a year (when I bought it) car skips and hesitates when I slow down then accelerate (might be spark plugs or something else🤷🏾)
o_O
 
1 - 20 of 96 Posts
Top