Honda Pilot - Honda Pilot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
First post here, thanks for all the great info so far.

We have a 2010 Pilot Touring, we have owned it for about a year with no problems up until now. About a month ago my wife started noticing that exactly half (left half) the radio/climate control/clock display would go out upon startup. Sometimes it would stay off for the entire drive, sometimes it would start working about ten minutes in. One thing to note, whenever the display was half working many of the radio buttons did not work. You could turn the volume up and down but you could not power the radio on or off.

In an effort to fix the issue, I read that disconnecting the battery and shorting the cables together can sometimes remedy the problem. So I did this, I was going out of town so it was left in this state for 4 days, when I returned and hooked it back the display now no longer works at all. The anti-theft light blinks, the navigation works, and the 12v plug works. I checked both the radio and accessory fuses, both checked out. But nothing on the radio screen, I put the unlock code in for the navigation and it works fine, but I did notice that when you press the "audio" button down below to adjust audio settings on the nav screen it has no response. I am sure I need to enter the radio unlock code, but with no screen that seems impossible.

Do I have any options here? I really hope i am not looking at a replacement.

Thanks in advance...
 

·
Registered
Joined
·
557 Posts
I don't have the touring trim, but in my EXL the radio buttons have gone dead before because the connection behind the button panel gets loose. We usually just push in on the plastic surrounding the buttons and then power cycle the radio and it works fine.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Update... I removed the entire radio/climate controls/navigation controls from the dash. I re-installed the units and now the display works. Great news! except the fact that now the radio will not accept the unlock that has worked in the past. Any ideas here? The navigation code works, but it will not take the radio code.
 
1 - 3 of 3 Posts
Top