Honda Pilot - Honda Pilot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Problem getting Iphone AND Ipod to both work when plugged in USB. <hr class="dividing-line">Hi there,

I use my 160gig Ipod for all of my music. I do not store any music on my iphone, but I may occasionally stream music from my iphone.

When I plug my Iphone up to the correct usb port, apple carplay shows up. If I THEN plug my Ipod up to the usb in the console, the Ipod never shows up accessible on my Audio Source menu.

When I reverse the connection order (Using the correct usb for Iphone and the usb in the console for my Ipod), the IPOD shows up when plugged up first and works fine, but then when I plug my Iphone in, the APPLE CARPLAY never shows up.

Can I only use 1 device at a time? I've tried plugging my Ipod in AFTER plugging up my phone, but when i try to touch the IPOD on my source menu, the controller thinks i want to play music from my phone. The screen never gives me an IPOD menu....only Iphone for music.

How can I use BOTH devices without interference.

Thanks for any help!!!!!!
Chad
 

·
Registered
Joined
·
882 Posts
I believe that only one port supports data transfer to the head stack, the others are just for charging devices. Have you tried attaching a USB hub to the port that interfaces to the audio stack? Not sure if Honda built in the logic to have it act like a USB port would on a computer. That is something you can try. Lenovo makes one that is unpowered and has four ports for 10 bucks on Amazon. Amazon.com: Lenovo 4-Port USB 3.0 Hub, Portable Data Hub Compatible For USB Type A Devices(Black-25): Electronics
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
HI there,

Thanks for the response. I can use my Iphone plugged into the appropriate port, just above the gear shift, left usb port. When I unplug my iphone, I can then plug in my Ipod using the usb INSIDE the sliding console area. Both devices work perfectly on the separate USB ports, however they both cannot be plugged in at the exact same time. Whichever device was plugged in last is the one that doesn't work. So Iphone by itself plugged into the correct usb above the gear shift it fine w/o the ipod plugged into usb INSIDE the sliding console storage area. And vica/versa. It's like the controller doesn't recognize both usb devices.

Basically the devices work fine individually on their own USB ports, just not at the same time. Very weird problem. Maybe Honda did not design it to work with 2 apple products at the same time??

Any suggestions? :)


Btw, I do have an unpowered hub I can try. I'll post my results.

Thanks,
Chad
 
1 - 3 of 3 Posts
Top