Honda Pilot - Honda Pilot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
Hello, I changed the upper and lower orings(orange on bottom and black on top)due to power steering whining. After a few weeks whining came back and I noticed fluid leaking/running out of the top of the pump where the high pressure line bolts on. I pulled the line back off and the black oring looks fine. I feel like it should be some sort of gasket on the mounting land. I don't know what else to do other than adding high temp RTV between the pump and high pressure line. ?‍♂ I verified that I ordered the correct part#. I attached a pic pointing out the leak.
 

Attachments

·
Registered
Joined
·
62 Posts
There has to be a cut in that O-ring or the hose is leaking. It could also be the incorrect size o-ring that they put in the wrong bag...
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
3,033 Posts
Did you torque the bolts to the required spec? Sorry, but I’m not sure what that value is.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
I ordered another OEM oring and verified the part#. Going change it and check the torque spec. Also bleed the system. Hopefully it works.
 

·
Registered
Joined
·
2,555 Posts
I ordered another OEM oring and verified the part#. Going change it and check the torque spec. Also bleed the system. Hopefully it works.
Hopefully from a different location ? i went into the dealership yesterday to buy two wheel nuts the dude tried to pass off 14 mm as 22 mm..i had to take one off my pilot and show him..
the stupid thing was twice the size of what he was trying to sell me. So there is a really good chance they sold you the wrong O -ring
 
1 - 5 of 5 Posts
Top