Honda Pilot - Honda Pilot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Howdy all! I have a 20006 Pilot, and I've always had a car charger plugged into the power outlet to charge my phone while driving. Everything had always worked fine up until about two weeks ago. I have a Samsung Galaxy S8+, and now when I plug my phone up I get a message on my phone saying it is "Slow Charging" (which it never did before when plugging it up in my car), and my battery would actually go down while plugged up. My son tried his plugging his phone up to it, and received the same message. I tried the two outlets in the arm rests with the same results. Any idea what is causing this?
 

·
Registered
Joined
·
6,199 Posts
Assuming fuses check out, maybe start by taking a multimeter to check your car battery voltage. How old is the battery?
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
3,043 Posts
Did you try a different charger?
 

·
Registered
Joined
·
6,199 Posts

·
Registered
Joined
·
2,555 Posts
Bad Class C cable ..
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I've tried two different chargers with three different cables. I bought the car used 2 years ago, and have not changed the battery.
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
3,043 Posts
I’d have to believe you’d have other electrical issues (such as the engine not cranking) if the battery was going bad, but if you have a voltmeter let us know what you measure across its terminals.
If you checked the fuses did you visually inspect them or measure them with an ohm meter?
 
1 - 7 of 7 Posts
Top