Honda Pilot - Honda Pilot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi All,


Anyone have any idea why my 2009 Pilt with 155K miles sputtered and died on the highway. Won't start or turn-over. Codes: P0300 all the way to 301-306

I'm thinking it might be

EGR ports under valve cover-clean-
EGR Valve
Idle air control valve
PCV valve
If so please email me at [email protected] and give me an estimate on what you think I need to do to get it running again.
 

·
Registered
Joined
·
1,760 Posts
Have you checked the battery voltage?
 

·
Registered
Joined
·
445 Posts
Start with the basics: does the engine have fuel? How about spark?

Fuel: empty tank? Fuel pump failed? Clogged fuel line? Cut or broken fuel line?

Spark: battery or alternator failure ? Ground cable failure? Fuse or relay bad? Crankshaft position sensor bad? Camshaft position sensor bad?
 

·
Registered
Joined
·
1,564 Posts
All those codes relate to fuel I agree with STMech on this one ..
 

·
Registered
Joined
·
130 Posts
Hi All,


Anyone have any idea why my 2009 Pilt with 155K miles sputtered and died on the highway. Won't start or turn-over. Codes: P0300 all the way to 301-306

I'm thinking it might be

EGR ports under valve cover-clean-
EGR Valve
Idle air control valve
PCV valve
If so please email me at [email protected] and give me an estimate on what you think I need to do to get it running again.
It won't turn over? I would start with the battery.
 

·
Registered
Joined
·
18 Posts
Not sure if im too late, but sounds like the alternator went bad and killed the battery.
 
1 - 7 of 7 Posts
Top