Honda Pilot - Honda Pilot Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I went to reseal my oil pan when I was finished with that I started it up and the drive gear on the dash is flashing and when I press on the throttle it has no power starting out my check engine light is throwing a P0748 code which is a pressure control solenoid so I spent the $200 on the solenoid and it did not fix the problem so I'm stuck with a part that didn't fix my problem at all so if someone could point me in a better direction that would be awesome
 

·
Registered
Joined
·
1 Posts
I went to reseal my oil pan when I was finished with that I started it up and the drive gear on the dash is flashing and when I press on the throttle it has no power starting out my check engine light is throwing a P0748 code which is a pressure control solenoid so I spent the $200 on the solenoid and it did not fix the problem so I'm stuck with a part that didn't fix my problem at all so if someone could point me in a better direction that would be awesome
I am having the same issue with 2004 Pilot. "P0748 ... Electrical". Only 1st and reverse gears are working. Changed Solenoid AB and C. Changed transmission fluid as well.
 

·
Registered
Joined
·
11,741 Posts
I am having the same issue with 2004 Pilot. "P0748 ... Electrical". Only 1st and reverse gears are working. Changed Solenoid AB and C. Changed transmission fluid as well.
Hello, hopefully someone here can help.
P0748
Possible Causes

  • Dirty transmission fluid
  • Low transmission fluid level
  • Faulty line pressure solenoid valve 'A
  • Line pressure solenoid valve 'A' harness is open or shorted
  • Line pressure solenoid valve 'A' circuit poor electrical connection
Milage?
How old was the ATF removed?
What ATF was used before?
What ATF did you use now?
Has all the above list been checked?
If any of the conections are dirty and oil soaked, I recommend cleaning inside and outside of these conections with CRC Electronic Cleaner.
 
  • Like
Reactions: STMech

·
Registered
Joined
·
1,058 Posts
I would check out the list that Nail Grease provided. The OP mentioned resealing the oil pan prior to the P0748 code appearing. Perhaps the transmission wiring harness was dislodged, or damaged during this work? How about the transmission grounding connections? A poor ground can cause problems. My next step would be to get the Pilot up on jackstands and check underneath with a good LED worklight for wires out of place or damaged.
 

·
Registered
Joined
·
11,741 Posts
I would check out the list that Nail Grease provided. The OP mentioned resealing the oil pan prior to the P0748 code appearing. Perhaps the transmission wiring harness was dislodged, or damaged during this work? How about the transmission grounding connections? A poor ground can cause problems. My next step would be to get the Pilot up on jackstands and check underneath with a good LED worklight for wires out of place or damaged.
Good call!
That transmission ground strap to the chassis may need attention.
This is a good substitute from Wal-Mart.
145352
 
  • Like
Reactions: The Todd

·
Registered
2008 Piot SE FWD, 2015 Pilot LX 4WD. 2005 GSX-R1000
Joined
·
2,190 Posts
Good call!
That transmission ground strap to the chassis may need attention.
This is a good substitute from Wal-Mart.
View attachment 145352
This is on my mental 'to do' list for my 08.

It doesn't need it for sure - yet, and it's to darn cold outside.
My closed garage got up to 26F this morning!
 
  • Like
Reactions: Nail Grease
1 - 6 of 6 Posts
Top