Honda Pilot - Honda Pilot Forums banner

101 - 112 of 112 Posts

·
Registered
Joined
·
1 Posts
I have a 2017 Honda Pilot Elite 20,000 miles. Just recently, I have no heat at idle or when I come to a stop light, I have the heat on, it cools down. It is currently at the dealer and they cannot find any issues, they are saying it is set from the factory this way. Does anyone else have this problem and what was your fix?
 

·
Registered
Joined
·
3 Posts
Geeter. The screw on my control valve was tight but the clamp that holds the cable coming from the firewall was disconnected. I wasn't sure where to clamp it so I tried a couple of different locations until I felt warm air from the front, but now I have cool air coming out of the back of the console, do you think I just need to find the perfect clamp location?
 

·
Registered
Joined
·
1 Posts
Wish me luck

i am not a car guy by any means and i started using this form a few days ago after my front console was only giving out luke warm air. This happened a day before we had -10 Celsius ( 14 F) and a snow storm was going to hit us in Ontario, Ca.
Anyways i took my pilot to the mechanic and first thing he said was replace heater core ( $1200 job).Apparently the heater core was plugged. Luckily, my colleague at work here heard about this issue and googled solutions.

The mechanic flushed the system for me and came back sayin the heat is coming only when the car accelerates.

I asked him to tighten the screw up on the control valve. I hope this fixes the problem. From all the posts i see here, I am relatively optimistic!!

Thanks.
 

·
Registered
Joined
·
4 Posts
Thank-you so much for this fix, you saved me so much time, trouble and money! I also sprayed some white lithium grease on the cable and cycled the heat a few times - worked great.
 

·
Registered
Joined
·
3 Posts
As I stated in post #102 of this thread my 04 is still blowing lukewarm air through the front vents and cold air through the rear vents(even when the control knob is turned to off). The valve at the firewall seems to work like it is supposed to, and the screw is tight with no rust and the plastic valve attached to it seems fine. Is my problem the "door actuator" mentioned in this thread or something else? I'm at a loss. I was hoping the "screw" would fix my problem.
 

·
Registered
Joined
·
45 Posts
Same heater issue, maybe clogged core but hoping not. Can it be flushed from firewall in engine compartment?? Thanks anyone

Sent from my SGP561 using Tapatalk
 

·
Registered
Joined
·
4 Posts
Mine is still not working correctly, now it's stuck on hot unless I turn it all the way down. Just have to replace the valve when the weather warms back up.

Here's a pic from another thread, I had to move one of the smaller hoses a little to see it.

Just wanted to say thanks to you and all others who explained this fix.
I had this issue a while back on my 06 Pilot and was able to get another year of heat with this fix.
Unfortunately the heat stopped working again, but hopefully I'll be able to find a solution here as well.

Thanks!
 

·
Registered
Joined
·
1 Posts
I have a 2004 Pilot. has stopped blowing heat from the front vents. The center console working fine with hot air and adjusts according tofront/rear controls. The blower fan up front fine, cycling the mode does not change the heat performance. A/c works fine. Is there fuses to check? are there 2 heater cores, 1 for front and back, or is this a heater core control valve problem. Can you easily diagnose the fault or is this a dealer job? thanks
I want to SAY THANK YOU FROM THE BOTTOM OF MY HEART I HAVE FIVE GIRLS I TAKE AND PIXK UP FROM SCHOOL AND MY HUSBAND AND I WAS FREZZING AFTER THREE MEN AT THE BODY SHOP WERE HE WORKS COULDNT FIX THIS PROBLEM THE exact same problem you WE WERE HAVING AND I TOLD MY HUSBAND ABOUT THIS POST AND SHOWES HIM HE FIXED IT BECAUSE OF U MERRY CHRISTMAS AND HAPPY NEW YEARS I HOPE U AND YOUR FAMILY HAVE A VERY VERY VERY BLESSED YEAR !!!!!!AND NOW MY FAMILY CAN BE WARM BECAUSE OF YOU!!!!TY TY TY !!!!!
 

·
Registered
Joined
·
3,740 Posts
Really glad to hear you got it fixed and your family is now warm and happy. All best wishes to you and yours. ?

Is this the fix that worked for you, the loose screw? What year is your Pilot?

 

·
Registered
Joined
·
1 Posts
Could someone please help and direct me too the post where the pictures are so I can see if it fixes my same problem. Would greatly appreciate sincei am about to drive up north from Florida and heat is a necessity...lol thank you
 

·
Registered
Joined
·
3,740 Posts
It's on page 2 of this thread. But it may originally come from an Acura MDX forum, I'm not sure.


Point is, read through the thread you're on, spray WD-40 on the screw, wait overnight if necessary for it to penetrate, then try to tighten that screw. Get help if you need it. Let us know how it works out.
 
101 - 112 of 112 Posts
Top