Honda Pilot - Honda Pilot Forums banner

81 - 100 of 134 Posts

·
Registered
Joined
·
50 Posts
I have had the keyless start issue since Nov 2019 on my 2016 Touring model but it was so intermittent it actually went away a few months. It would come on periodically with both keys, both keys with new batteries as well. I finally had a chance to take it in to the dealer while the light was on. They claimed it was actually the start/stop button causing the issue. They replaced it and the light has not come back on for a week now so they might have been spot on. I think it was a $240 line item with labor but thankfully the extended warranty covered it.
 

·
Registered
Joined
·
3 Posts
I have the same issue with the keyless starting issues for more than 4months and i think it has something to do with the foot brake.
This might work if you guys wanted to try. Before you turn off the engine press the foot brake or parking brake, give it a least 30 seconds to reset and then start the engine again, see if the message go away.. Its been a week now and message has not come back yet. Hope this solves your problem too.
Worked for me! Replaced the remote battery and then tried what you wrote. Had to turn off/on the engine 2 times and light went off. Thanks
 

·
Registered
Joined
·
10 Posts
i had the same issue after my "walk away lock feature" stopped working . the stealerships did a reset of the unit and it works now and no errors but its been only 2 days lets see if it holds up
i'm having the same issue too with my 2016 Honda Pilot EX-L with the walk way locking feature. it happen to me about a month ago when i notice that my walk away lock feature is not working, so i double check with my settings and it's still not working. Then the message pop up saying keyless start system problem. i youtube/googled the problem and they all replaced the on/off push start switch which fixed the problem. so i order the part and switched it, it's been a few days but no pop up on my dash. But the walk away feature if not locking it self. just wanted to see what did the mechanics at honda did for your honda for the walk away to lock itself.
 

·
Registered
Joined
·
1 Posts
I have the same issue with the keyless starting issues for more than 4months and i think it has something to do with the foot brake.
This might work if you guys wanted to try. Before you turn off the engine press the foot brake or parking brake, give it a least 30 seconds to reset and then start the engine again, see if the message go away.. Its been a week now and message has not come back yet. Hope this solves your problem too.
it worked for me
 

·
Registered
Joined
·
208 Posts
I had this notification too. It turned out that the push button start shorted out and they replaced it under warranty. I was told, this happens quite a bit.
 

·
Registered
Joined
·
18 Posts
Worked for me! Replaced the remote battery and then tried what you wrote. Had to turn off/on the engine 2 times and light went off. Thanks
Most likely your “success” is just a coincidence. When the problem first presents itself, the “Keyless Start System Problem” error only displays once in a while. Later it becomes worse and there nearly every time the car is started. You will likely need to have the start button replaced.
 

·
Registered
Joined
·
18 Posts
it worked for me
Most likely your “success” is just a coincidence. When the problem first presents itself, the “Keyless Start System Problem” error only displays once in a while. Later it becomes worse and there nearly every time the car is started. You will likely need to have the start button replaced.

Please be sure to report back in a month To let us know. Thank you
 

·
Registered
Joined
·
1 Posts
I have Honda Pilot 2016. I have the message (Keyless Entry System Problem). The walk-away door auto lock feature stopped working. My dealer successfully fixed the problems:

Pay attention to the followings:

  • When the dealer scans your car, nothing will be detected!.
  • My dealer replaced the unit coded: 35881-TG7-A03 SW ASSY START STO (this is how it appears on my invoice)
  • After installment of the new unit, the dealer re-programmed all the keys (driver 1 and driver 2).
Things went back to normal:The alert message is gone and the walk-away auto-lock feature successfully became functional again.

I hope this helps.
Has this fixed the problem? I have a 2016 pilot I’ve had to jump off a couple of time in the past few days.
Do you remember what the dealership charged? Thanks!
 

·
Registered
Joined
·
5 Posts
It's a progressive problem, I think. Problem started when, I'm presuming, auto lock with walking away stopped working. Then error message on dash "keyless start system problem" with no recognizable problems beyond the auto lock. Then had to start hitting start/stop button a couple of times to get it to start. Tried switching out fobs, replacing batteries in fobs. Checked this forum, stomping on brake pedal harder and letting up when trying to start, worked a bit then less so with time. It's been a running joke and my husband rolls his eyes at me and my POS Pilot. Now I have problems getting the car to turn OFF in addition to problems getting it to start. Have held remote start in reserve for the day when everything else fails (tried it today, worked okay), but ordered new start/stop button (Google works wonders to find the part, 35881-TG7-702) and will use YouTube video (thank you!) to replace switch myself. Facing dash removal with trepidation, but will put my big girl pants on and get it done.

Have already addressed judder and emissions system problems with this car, what's one more? (Have more pics and videos on my phone of my Pilot instrument cluster than of my kids at this point) Honda should compensate us for beta-testing their redesign for them!
 

·
Registered
Joined
·
5 Posts
It's a progressive problem, I think. Problem started when, I'm presuming, auto lock with walking away stopped working. Then error message on dash "keyless start system problem" with no recognizable problems beyond the auto lock. Then had to start hitting start/stop button a couple of times to get it to start. Tried switching out fobs, replacing batteries in fobs. Checked this forum, stomping on brake pedal harder and letting up when trying to start, worked a bit then less so with time. It's been a running joke and my husband rolls his eyes at me and my POS Pilot. Now I have problems getting the car to turn OFF in addition to problems getting it to start. Have held remote start in reserve for the day when everything else fails (tried it today, worked okay), but ordered new start/stop button (Google works wonders to find the part, 35881-TG7-702) and will use YouTube video (thank you!) to replace switch myself. Facing dash removal with trepidation, but will put my big girl pants on and get it done.

Have already addressed judder and emissions system problems with this car, what's one more? (Have more pics and videos on my phone of my Pilot instrument cluster than of my kids at this point) Honda should compensate us for beta-testing their redesign for them!
Found the part online easily, ordered ($72 total with slowest shipping, still made it within 2 days), pulled off dash with my bare hands starting at bottom left no flat head needed but did need a Phillips near the switch, unclipped and unplugged start/stop, plugged in new switch and tried it. Eureka!! Clipped it in place, reattached dash with a few well-placed whacks, and all good. Took less than 10 minutes. Don’t think the walk-away auto-lock is fixed, but that’s life in the big city. Thanks to all before me for details on this!
137707
 

·
Registered
Joined
·
5 Posts
Has anyone tried before replacing the push button, to just unplug it and re-plug it back in. Thinking the computer might do a reset that may fix it. I wonder if anyone has had success trying this. I could try this on mine soon and see what happens, I guess it wouldn't cost anything to try.
 

·
Registered
Joined
·
1 Posts
I have 55,000 miles on my Pilot 2016 and have been having this problem intermittently now. I’m very grateful that there is a quick, easy fix that I can do myself. The man in the video completed the repair in 7 minutes! I plan to try it rather than waste $300+ on a repair that would take a service technician less than 15 minutes to complete
 

·
Registered
2016 EXL AWD Nav with sensing , 2008 Corolla SE
Joined
·
402 Posts
I have 55,000 miles on my Pilot 2016 and have been having this problem intermittently now. I’m very grateful that there is a quick, easy fix that I can do myself. The man in the video completed the repair in 7 minutes! I plan to try it rather than waste $300+ on a repair that would take a service technician less than 15 minutes to complete
I just replaced mine too. It's an easy job that anyone can do themselves in less than 15 minutes with nothing more than a Phillip's screwdriver so why would you pay a dealer $300 to do it. Interesting to note though that the Genuine Honda part is made in Mexico.
 

·
Registered
Joined
·
5 Posts
Has anyone tried before replacing the push button, to just unplug it and re-plug it back in. Thinking the computer might do a reset that may fix it. I wonder if anyone has had success trying this. I could try this on mine soon and see what happens, I guess it wouldn't cost anything to try.
I just tried this and it did not work, FYI. However it was easy to take the panels off. So I ordered the push button from amazon for $44.25!!!! I hope it works!
 

·
Registered
2016 EXL AWD Nav with sensing , 2008 Corolla SE
Joined
·
402 Posts
So I ordered the push button from amazon for $44.25!!!! I hope it works!
I saw those buttons on Amazon but decided to go with the made in Mexico "genuine " Honda part instead of the Chinese knock offs. Please let us know how it works out.
 

·
Registered
Joined
·
5 Posts
I saw those buttons on Amazon but decided to go with the made in Mexico "genuine " Honda part instead of the Chinese knock offs. Please let us know how it works out.
So, I got it installed. The text was in fact upside down like I have seen in other comments, however all I had to do was spin the push button upside down before snapping it back in. I am on day 3 of it being in and no error message so far. I think it worked.
 

·
Registered
2016 EXL AWD Nav with sensing , 2008 Corolla SE
Joined
·
402 Posts
So, I got it installed. The text was in fact upside down like I have seen in other comments, however all I had to do was spin the push button upside down before snapping it back in. I am on day 3 of it being in and no error message so far. I think it worked.
Glad it worked. If it happens to me again, I will try one of those buttons at half the cost.
 

·
Registered
Joined
·
1 Posts
I have the same issue with the keyless starting issues for more than 4months and i think it has something to do with the foot brake.
This might work if you guys wanted to try. Before you turn off the engine press the foot brake or parking brake, give it a least 30 seconds to reset and then start the engine again, see if the message go away.. Its been a week now and message has not come back yet. Hope this solves your problem too.
It is worked for me. but little bit different way. Used brand new Duracell car battery for fob. I pressed the foot brake and keep car shift in Drive mode with on Hand brake wait 30sec then turn off the engine. then change the car shift in P mode and press switch keep car fully off. After few second I pressed ON for start the Engine and no error mess showed. Let see in future. I will keep update my post.

(Honda pilot 2016. KM45k. 1st error massage showed Nov 2019. Every day I see the massage after start the car.)
 

·
Registered
2016 EXL AWD Nav with sensing , 2008 Corolla SE
Joined
·
402 Posts
It is worked for me. but little bit different way. Used brand new Duracell car battery for fob. I pressed the foot brake and keep car shift in Drive mode with on Hand brake wait 30sec then turn off the engine. then change the car shift in P mode and press switch keep car fully off. After few second I pressed ON for start the Engine and no error mess showed. Let see in future. I will keep update my post.

(Honda pilot 2016. KM45k. 1st error massage showed Nov 2019. Every day I see the massage after start the car.)
Like most folks who drive cars with automatic transmissions, and live in the flat lands, I have never used the parking brake and I still got the Keyless Start System Mal. so I doubt in my case that it had anything to do with the parking brake. I did a scan with my Bluedriver and pulled a B12C5 error code on the stop/start switch so I replaced the switch as the code kept coming back. So far everything has been good so I am pretty sure it was the switch.
 
81 - 100 of 134 Posts
Top