Honda Pilot - Honda Pilot Forums banner

1 - 20 of 32 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
As the temps rise I noticed my air conditioning was running very randomly at best. Some rides are nice and cool while others it was clear the compressor was not running. My first thought was to check the freon charge.

One afternoon I was lucky to come home from the office with the a/c running. I followed the service manual system test to find the charge was marginally low. I added some freon to dial in the high and low pressures... going for something in the middle of the acceptable ranges.

This, unfortunately, did not solve my issue. Through additional diagnostics I discovered the a/c compressor relay was very intermittent... the root cause of my issue. A quick internet search to see if the Omron relay is available in the aftermarket led me to find the Omron relay, a Honda specific part with a reduced coil current, is known to be problematic. Honda is replacing it with a Mitsuba relay.

The Omron relay part numbmer is: 39794-SDA-A03

The Mitsuba relay part number is: 39794-SDA-A05

There are 5 of the Omron relays in the under hood fuse-relay box. They control:

A/C clutch
Radiator fan
Condensor fan
Electronic throttle control
PGM-FI sub-relay

I hope this bit of information will help anyone who finds themselves with a malfunctioning a/c system. Given the known issue with the Omron A/C clutch relay a quick test may save you trip to your mechanic.
 

·
Registered
Joined
·
12 Posts
Great post!! My 2009 Touring had intermittent AC and this was the exact issue.
I swapped the relay with the fan relay (same relay) and the compressor kicked right on!
Now I just need a new relay.

Thanks !!
 

·
Registered
Joined
·
14 Posts
Intermittent AC. Saw this post. Bought new relay for $15.99 and we're back 100%.

Parts Manager at Brantford Honda did not even have to look up the part - knew it right away. Must be happening all the time.

Said it fails due to the heat of the engine compartment and the AC clutch relay is closest to the engine of the bunch in the housing.

Thanks to forum for saving at least $100 in diagnostic costs!

j
 

·
Registered
Joined
·
4 Posts
When you guys say intermittent, do you mean the air is cold and then hot, or that the vents blow air sometimes and not others? My front two middle vents sometimes blow air and sometimes don't. It's been more don't lately, do you think these relays will fix my problem? I'm getting cold air at my feet and the side vents (a little), just no blowing from the middle vents. Should I replace this fuse?
 

Attachments

·
Registered
Joined
·
40 Posts
Discussion Starter #11
When I was dealing with this issue I had warm/hot air blowing from all vents. My issue was the compressor clutch not engaging. Air from some vents and not other vents sounds more like a damper/door issue in the duct work.

If you are getting warm air you can open the hood to see if the A/C compressor clutch is engaged. If not, this relay may be the culprit.
 

·
Registered
Joined
·
1 Posts
Warm air on the driver side, cold air on the passenger side

When I was dealing with this issue I had warm/hot air blowing from all vents. My issue was the compressor clutch not engaging. Air from some vents and not other vents sounds more like a damper/door issue in the duct work.

If you are getting warm air you can open the hood to see if the A/C compressor clutch is engaged. If not, this relay may be the culprit.
Warm air on the driver side, cold air on the passenger side and sometimes all is right with the world...Any thoughts on where I should look?

In the winter it's reversed, good thing I live in the south.
 

·
Registered
Joined
·
8 Posts
Same issue on my 2010. On hot days it would blow warm are now and again for 30-45 seconds. Then the last few days it just completely stopped working. I pulled the relay. Gave the relay a good tap on a hard surface (But should not matter since i think its a solid state relay anyway). I put it back in and its working again. Going to buy a new relay.


Also note. Look under the truck at the front air shroud under the bumper. There is a plastic door in the shroud 4x7 inches or so. Open it up can you can them see the bottom of the AC compressor and vent relief valve. If your system over pressurized it may vent oil out this valve.. See section 21-92 in the repair service manual. This might give you a hint if your low on refrigerant. I heard once the system vents you should replace the valve.
 

·
Registered
Joined
·
4 Posts
I took my Pilot in to CarMax about a year ago. I pointed them to this thread after testing it with another relay. They called me back saying that will not fix it. So they installed a new AC compressor. When I got it back, I noticed that they relay was new too. Guess they were wrong. Not a bad deal getting a new AC compressor out of it though lol.
 

·
Registered
Joined
·
3 Posts
Hi all. Really appreciate all the info on this thread. My issue is similar but a bit different. I had the relay issue and had that replace by the dealer at no cost. Nice guys. Now I have cold air up front and hot in the back. This is a 2011 Touring with rear controls. Any ideas? I've read about relay's and such but they all seem to be related to the fan which is working fine. Recently had the system recharged as well.
 

·
Registered
Joined
·
1 Posts
When you guys say intermittent, do you mean the air is cold and then hot, or that the vents blow air sometimes and not others? My front two middle vents sometimes blow air and sometimes don't. It's been more don't lately, do you think these relays will fix my problem? I'm getting cold air at my feet and the side vents (a little), just no blowing from the middle vents. Should I replace this fuse?
I did not see an answer/solution to this question. This sounds like the issue I have. The front vents sometimes seem to stop blowing air, but the rear vent still blows cold air. I'm going to try the relay, but was wondering how to troubleshoot if it is a damper/door issue?
 

·
Registered
Joined
·
3 Posts
Need help please, my 2010 Pilot blows cold and hot air from all vents but my driver side only not blowing cold air I have changed the relay but still the same issue any suggestions?
 

·
Registered
Joined
·
1 Posts
I have this exact same issue. Did you ever get it resolved? If so, what was the problem and how did you fix it.

Thank you!
 
1 - 20 of 32 Posts
Top