Honda Pilot - Honda Pilot Forums banner

I need the Piloteers help- my pick up truck....

3299 Views 22 Replies 8 Participants Last post by  Nail Grease
Hello, my 'ol Pick Up Truck needs help. I don't drive it much anymore because of the suspension rust and the mileage, etc. It normally runs great however. I thought it was the Fuel pump. I've changed it before ~8 yrs ago. Recently I think it's been acting up again.
I have put a pressure gauge on the fuel rail- and when it runs- it's with in spec- 48PSI.
Sometimes it won't start and no reading on the pressure gauge. Other times it starts, 48#, and yesterday near my home it ran poorly- like the fuel pump is intermittently gong out.
When it wouldn't start, I sprayed something in the throttle body, it would fire over briefly- hence I feel it is a fuel flow issue. Randomly other times, it starts right up.
* I checked the codes today - Zero codes! If the fuel pump had occas. low pressure- THAT should throw a code- even w/o a dash check engine light.

I've checked the 2 fuses that could keep the fuel pump from working, and swapped regulators around, no difference.

Today, I started it and drove it in my neighborhood again. Once it had a dying like idle- never died.

I bought another fuel pump- top of the line one from Rock Auto. However with the NO Codes thing- I'm not so sure that it is the fuel puimp?

* Changing it is a MAJOR PITA- the straps that hold it up are so rusted, etc.

My favorite local shop quoted $650- with THEIR fuel pump- they will not install a brand new one I have.

So, what else, sensor?, etc. could make this happen? Your thoughts? Anyone? Beuller? Silver7? Nail Grease? PlPlPl, etc/?
21 - 23 of 23 Posts

· Registered
2008 Piot SE FWD, 2015 Pilot LX 4WD. 2005 GSX-R1000
Joined
·
2,215 Posts
Discussion Starter · #21 ·
Update:
Late one at that.

So a few weeks ago I completed the Fuel pump Change. I did it in stages.
I actually got it to start, and drove it into my garage! Put the left side and rear on some jack stands too. This made it easier in my garage than on the street.



It was a BEEEEATCh too. Things all rusty, etc.
I managed to get the bolts holding the straps off! Propbem was though, the whole stud came out of the keeper thing in the frame. I managed to 'build' some more using some studs and nuts from my local ACE hardware!

The inside of the gas tank looked really clean too!

Got it back in, started right up!

I've driven it several times now, no problems. Oh I love the manual tranny!

I have the bed cover/shell off and will be putting my motorcycle in the back and driving it to a 2 day Track Day event this weekend!
 

· Registered
2008 Piot SE FWD, 2015 Pilot LX 4WD. 2005 GSX-R1000
Joined
·
2,215 Posts
Discussion Starter · #22 ·
As planned,
Last weekend I did a 2 day Track Day on my GSX-R1000 at a track about 90 minutes away!
But instead of renting the Uhaul M/C trailer and sleeping in the Pilot with the 2nd and 3rd row down,
I hauled it in my truck, and slept in the bed with my canopy over the bed (instead of across the back seat).
It was an awesome weekend!
I even got my 'bump' to Intermediate group on my 3rd track day!









I did 251.6 track only miles last weekend! Hitting just over 145mph on the short front straight.



My tires at the end of the weekend. Bridgestone S21's. (If only I'd would have had some Sumitomo's!)



There's 259K miles on the Dakota! Love the 4.7 L V8, and the manual transmission!

It's a truck (pick up).

This is the bed when I got home in my garage. I had things in the back seat area of the cab too.



This is the same bike arriving early for the bike night last Thursday at the Iron Horse Hotel- Milwaukee.

 

· Registered
Home of the 306k 2012 V6 Honda Crosstour
Joined
·
15,011 Posts
As planned,
Last weekend I did a 2 day Track Day on my GSX-R1000 at a track about 90 minutes away!
But instead of renting the Uhaul M/C trailer and sleeping in the Pilot with the 2nd and 3rd row down,
I hauled it in my truck, and slept in the bed with my canopy over the bed (instead of across the back seat).
It was an awesome weekend!
I even got my 'bump' to Intermediate group on my 3rd track day!









I did 251.6 track only miles last weekend! Hitting just over 145mph on the short front straight.



My tires at the end of the weekend. Bridgestone S21's. (If only I'd would have had some Sumitomo's!)



There's 259K miles on the Dakota! Love the 4.7 L V8, and the manual transmission!

It's a truck (pick up).

This is the bed when I got home in my garage. I had things in the back seat area of the cab too.



This is the same bike arriving early for the bike night last Thursday at the Iron Horse Hotel- Milwaukee.

Well if you want a Sumitomo motorcycle tires, buy Dunlops. 😁
Organism Output device Font Rectangle Magenta
 
21 - 23 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top