Honda Pilot - Honda Pilot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
846 Posts
Discussion Starter · #1 ·
Just saw this over on the Odyssey board. It mentions only the 2019-2020 Pilot, Passport, and the 2018-2020 Odyssey

134587
 
  • Like
Reactions: Tanner

·
Registered
Joined
·
846 Posts
Discussion Starter · #3 ·
With cars being so complicated nowadays..... at least Honda is trying......
For those having the problem however, it has been over several years already, correct?
 

·
Registered
Joined
·
70 Posts
From reading, it seems that some had their blue ray player cable rerouted and it fixed the problem. Does any honda techs here know where or how to route this cable? My 2020 EX-L (that's right not elite/touring) is starting to have popping at around 1,400 miles.
 

·
Registered
Joined
·
25 Posts
Hello lunarsilver, most cases I have worked on have the issue in the rear tuner amplifier unit. They have the incorrect routing that is causing stress on the most network wires. Very few vehicles have the issue on the blue ray players. Every vehicle I have worked on I inspect all connectors including behind the meter. Here is an example of the problem I have seen. See the way the red and green cables bend.
134791
 

·
Premium Member
Joined
·
376 Posts
After five trips to the dealer so far where all of this nonsense was tried:

134799
 

·
Registered
Joined
·
70 Posts
Hello JRGOMEZ,

Thank you for the pictures, I removed the head unit and blue ray. I cut the wire looms and loosen the wires a bit. I then wrapped them in tessa (similar to electrical tape) and that seems to fix the problem. This is on a 2020 ex-l.
 

·
Registered
2018 Pilot EX AWD
Joined
·
250 Posts
Thanks for posting those pictures Jrgomez. Though I have a 2018 and no problems I appreciate you coming on here explaining what the issue is and providing pictures to back it up.
 
1 - 10 of 10 Posts
Top