Honda Pilot - Honda Pilot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
It’s great that there are parts compatible between the MDX and Pilot. Picked up a steal on a used hitch from a 2014 MDX for $60. Ordered 6 bolts ($30) from my local Honda and the cover ($26). I’ve already taken the stock bumper cover off and need to clean up the hitch. Will update when complete.
CDC34844-8C01-4C6C-B407-05349F0050DB.jpeg
 

·
Registered
Joined
·
243 Posts
Good deal! Others who have installed the hitch themselves recommend installing the wiring harness before the hitch. I did, but I really don't see where it would make much difference. Most go with aftermarket harness from Etrailer rather than Honda, especially if you don't need the electric brake connections.
 

·
Banned
Joined
·
379 Posts
Cool. I paid about $135 for my hitch and maybe $35 for wiring. Easy install. I installed on my 2017 pilot. When I traded up to 2019 I made sure to take it off of course and put it on new one. The only thing I forgot was the fuse under the hood. When I hooked everything up and my trailer lights didn't work I was going nuts trying to figure it out lol. I watched a video on etrailer and duh, the fuse! I had to get one of course and everything was fine. Don't forget that fuse lol.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #4
Good deal! Others who have installed the hitch themselves recommend installing the wiring harness before the hitch. I did, but I really don't see where it would make much difference. Most go with aftermarket harness from Etrailer rather than Honda, especially if you don't need the electric brake connections.
Thanks! I agree, I will be ordering the wiring from eTrailer too. I just need the 4 pin.

Cool. I paid about $135 for my hitch and maybe $35 for wiring. Easy install. I installed on my 2017 pilot. When I traded up to 2019 I made sure to take it off of course and put it on new one. The only thing I forgot was the fuse under the hood. When I hooked everything up and my trailer lights didn't work I was going nuts trying to figure it out lol. I watched a video on etrailer and duh, the fuse! I had to get one of course and everything was fine. Don't forget that fuse lol.
Thanks for the heads up. Just saw the Curt harness. It doesn't look like all the paneling needs to come off to connect the harness after reviewing the video.
 
1 - 4 of 4 Posts
Top