Honda Pilot - Honda Pilot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I purchased my 2003 honda pilot about 2 months ago and everything was great until for some reason my front heat stop working. I get heat in the rear but not in the front. All i get is cold air through the front while the rear gets heat. I checked the blower and works fine. I checks antifreeze and is top off with no discoloration. I checked the line leaving the fire wall and is working good. I checked actuator under dash next to gas petal and it works. Idk what else to check. Also to top it off randomly the heat started to work the other day but then the next day it stopped. Please help now its getting cold outside thank fellow pilot brothers
 

·
Registered
Joined
·
447 Posts
I just checked an old thread on this problem. The lever on top of the heater control valve loosened up, so failed to move the valve. Inspect the control valve, lever, and pivot screw for looseness.
 

·
Registered
Joined
·
1,763 Posts
What STMech said. That’s the first thing that came to mind after reading the symptoms.
 

·
Registered
Joined
·
2,087 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Heat issues

Hey guys ive been trying to figure out how to reply but i had already checked that out like i said in discription. It opens and closes fine.
 

·
Registered
Joined
·
1,763 Posts
I’m surprised it’s not that valve. That makes three of us who guessed incorrectly. :)
Try burping the air bubbles out of the cooling system. You may have an air pocket which is trapped in the front heater core.
 

·
Registered
Joined
·
1,763 Posts
Also have you confirmed both blowers work?
 

·
Registered
Joined
·
2,087 Posts
I checked the line leaving the fire wall and is working good.
You checked the line, but did you check the screw? Just checking you checked it isn't loose. :smile:
 
1 - 9 of 9 Posts
Top