Honda Pilot - Honda Pilot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I drive an 04 Honda Pilot, and this doesn't happen all the time, just some of the time. It has good fluid, and the level has always been good.
Yesterday I changed the inline(external) filter, and pulled the shift solenoid and cleaned it up (even though it was nice and clean), but it didn't make any differences. Today I'm thinking about resetting the TCM, I am starting to run out of ideas. I also wonder if the speed sensor might have something to do with to, but IDK. Any help is deeply appreciated !
 

·
Registered
Joined
·
1,649 Posts
Also check the adjustment of the shifter cable, that can throw off transmissions.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I move it to neutral and then back to D and sometimes it works and sometimes it doesn't. I can drive around in 1 and 2 all day, no problems, only when in D it seems to be giving me problems.
 

·
Registered
Joined
·
1,649 Posts
Yeah, check the cable for sure.
 

·
Registered
Joined
·
3,736 Posts

·
Registered
Joined
·
2 Posts
I have an 04 4wd and when you put the car in drive 9 times out of 10 nothing happens. You are pretty much in neutral. When you go down to 1, it drives fine and once the car is moving shifting into drive works just fine. But from a stop nothing happens. Ive replaced the a and b solenoid and taken all of the solenoids out and cleaned them. I have also done about 4 fluid changes now.
 

·
Registered
Joined
·
3,736 Posts
H
I have an 04 4wd and when you put the car in drive 9 times out of 10 nothing happens. You are pretty much in neutral. When you go down to 1, it drives fine and once the car is moving shifting into drive works just fine. But from a stop nothing happens. Ive replaced the a and b solenoid and taken all of the solenoids out and cleaned them. I have also done about 4 fluid changes now.
Shifter cable?

2003 Pilot Shifter Loose

Hard to shift
 
1 - 10 of 10 Posts
Top