Honda Pilot - Honda Pilot Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
i recently noticed my engine temp rising while idling i understand this is normal but the temp doesn't star to go down until i starr moving. This is happening in very mild weather. The fans don't seem to becoming on and the temp can get up to 185. i also have a pending p3400 code.
 

·
Registered
Joined
·
1,019 Posts
FWIW, the efans on a Gen 2 Ridgeline (same 3.5L motor) do not turn on until 205F ECT.
 

·
Registered
Joined
·
11,364 Posts
Do the fans come on when the AC compressor is on?
 

·
Registered
Joined
·
11,364 Posts
yes they dp
As said, for the cooling fan to kick on by the temperature sensor, it must reach 205°F. The fans should run until the the engine reaches 190°F and turn off.
What is the year model, trim and milage of your Pilot?
P3400 is a very easy fix, but recommend you do not drive your vehicle with this code. It is a 3 of 3 severity. P3400 is pertaining to the vtec oil pressure switch located on the drivers side back head, not at dipstick. This part can be bought at most auto parts store and comes with the O-ring. This video should help. Double check part numbers. This video is on a 2009. It's pretty much the same.
 
  • Like
Reactions: aggrex and AVC

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
I have already replaced that still getting it as a pending code CEL is would my vcm muzzler be the problem?
 

·
Registered
Joined
·
11,364 Posts
I have already replaced that still getting it as a pending code CEL is would my vcm muzzler be the problem?
No. The Muzzler won't cause this.
After replacing the vtec oil pressure switch, you should have noticed the engine running better. Was this the case? If the engine seems to be running fine, erase the pending code and see if it comes back.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
there was never any with the engine running poorly. i cleared the code. when i restart the engine my real-time info for torque pro reports that there is a p3400 code pending but the CEL doesn't come on and the engine runs fine
 
1 - 8 of 8 Posts
Top