Honda Pilot - Honda Pilot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Last Friday 9/27/2019 our pilot stopped running, flashed the "Check Charging System" Error and the battery light was on. Loud squealing noise coming for under the hood. Towed it home and changed the alternator and the battery. It ran OK until today and the same error occurred. My wife has driven it back to her work without any issues. Any ideas on how to diagnose this problem...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Last Friday 9/27/2019 our pilot stopped running, flashed the "Check Charging System" Error and the battery light was on. Towed it home and changed the alternator and the battery. It ran OK until today and the same error occurred. My wife has driven it back to her work without any issues. Any ideas on how to diagnose this problem...
 

·
Registered
Joined
·
439 Posts
Did you check the condition and fitment of the cables? What is the condition of the accessory belt and tensioner? Did you get any voltage readings before and after the alternator change?
 

·
Registered
Joined
·
453 Posts
Loud squeal sounds like accessory belt problem, as suggested above. Check tensioner, belt condition, also if A.C. compressor pulley has locked up, interfering with belt and alternator rotation.
 

·
Registered
Joined
·
1,788 Posts
Don’t forget to check the negative battery cable as well. But as mentioned above squealing is likely belt/tensioner related.
 
1 - 5 of 5 Posts
Top