Honda Pilot - Honda Pilot Forums banner

241 - 260 of 341 Posts

·
Registered
Joined
·
84 Posts
Good morning and Happy Holidays!


Quick question for everyone using the Autoplay Dongle; I've had mine for a few months, and everything was working fine until about 4 weeks ago. I'd plug it in, get CarPlay running with Waze and such, then after about 30 minutes, give or take, the screen would start going bonkers and the dongle would disconnect, and then you'd have to restart the AutoPlay app over and over. Quite disconcerting and annoying.

Has anyone else had this issue? If you have, did you resolve the problem, and if you did, how did you get it to stop? I got a more recent image from this link - http://112.74.112.110/download/ and will be trying to update the program from a USB drive, as maybe something got messed up on the head unit.


Please post any info that you have regarding this, and I will update my results back here tomorrow.


Thanks!
 

·
Registered
Joined
·
84 Posts
Good morning and Happy Holidays!


Quick question for everyone using the Autoplay Dongle; I've had mine for a few months, and everything was working fine until about 4 weeks ago. I'd plug it in, get CarPlay running with Waze and such, then after about 30 minutes, give or take, the screen would start going bonkers and the dongle would disconnect, and then you'd have to restart the AutoPlay app over and over. Quite disconcerting and annoying.

Has anyone else had this issue? If you have, did you resolve the problem, and if you did, how did you get it to stop? I got a more recent image from this link - http://112.74.112.110/download/ and will be trying to update the program from a USB drive, as maybe something got messed up on the head unit.


Please post any info that you have regarding this, and I will update my results back here tomorrow.


Thanks!


Update 12/21/2018 - first chance to take a long drive since experiencing this issue. 2016 Honda Pilot EXL AWD. I narrowed it down to the 12V/USB power. I noticed that I had my Garmin GPS plugged into the 12V outlet, my iPhone and dongle (running the CarPlay) plugged into the left hand USB, and my wife's iPhone plugged into the right side USB to charge. Once I unplugged the 12V plug for the Garmin, and unplugged my wife's phone, no problem. My adult son (going with us on this trip) needed to charge his Anker power pack. I remembered that CarPlay has a setting for high power or low power charge, changed from the high power to low power charge for the phone. Son plugged his power pack in and charged just fine, as did my iPhone while using the CarPlay. So, it appears that the USB plugs and the 12V accessory plug share the same 12V power supply line, and if taxed too much, the dongle doesn't get an adequate voltage and shuts down, then doesn't connect. Once I made that change, and didn't use the 12V accessory, the CarPlay stayed connected.

One other thing, while I'm thinking of it: if one loses audio when using Waze for voice directions, make sure you have the Audio Apps option selected. A couple of times I accidentally touched something on the head unit display and wound up switching to another audio option. Make sure you click on Audio -> Audio Apps to re-engage the Waze voice directions.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Just wanted to report my success story of using Honda Hack Pro on a 2016 Honda Pilot EX-L and got CarPlay working
using the AutoKit installer built into Honda Hack.

I bought the USB CarPlay adapter from amazon at https://www.amazon.com/gp/product/B07HCKWDJ1 "Carlinkit USB Car Play Dongle Electronics Cable Connector (HW01-01)"

Here is a picture of it running:
 

Attachments

·
Registered
Joined
·
27 Posts
Just wanted to add that the latest AutoKit update was very significant and worth the effort. Very stable, added features such as the ability to configure the car manufacturer logo to the car icon in CarPlay, key mapping (in beta), and screen mirroring if for some reason you want to do that. I can imagine that would be nice for videos, but the screen is only mirrored, not controllable from the touch display.

Anybody had any luck in bypassing the double permission dialog prompt from AutoLink upon every single startup? Does HondaHackPro provide any way around this?

Thanks!
 

·
Registered
Joined
·
4 Posts
Hi all,

Long time lurker and want to provide feedback on recent upgrade experience with my 2016 Honda Pilot EX-L. I bought the $25 Honda hack pro from Honda Hack – Learn how to root your Honda head unit and install apps.. The registration code was delivered immediately and I installed the HondaHack.apk via USB(fat32) on the same day without a problem. I used Waze via phone tethering a few weeks while waiting for my Dongle to arrive from China. While it crashed or freezed from time to time, I generally didn't have any issue with its operation.

I ordered the USB Dongle from 1haodian2013 (USB Carplay Dongle For Apple iPhone Android Car Auto Music Navigation Player 760450924003 | eBay) around the new year. I received the Dongle from China today. Using the AutoP client that comes with Honda Hack Pro, I was able to successfully connect to Android Auto! The operation thus far has been smooth and trouble-free. My box version in configuration screen shown as: 2018.09.21.1617 and software version is shown as: 2018.11.16.1407. The USB port used is the one that 1.5 Amp (not the rightmost one). My phone is a Oneplus 6.

Interestingly, not all of the USB-C cables work. Out of the 4 cables I tried, two work, two didn't. I am currently using a cheap replacement cable from Amazon (vendor cable matters). If anyone needs clarification on the installation process, please ask and I will try my best to provide information.
 

·
Registered
Joined
·
4 Posts
Just wanted to add that the latest AutoKit update was very significant and worth the effort. Very stable, added features such as the ability to configure the car manufacturer logo to the car icon in CarPlay, key mapping (in beta), and screen mirroring if for some reason you want to do that. I can imagine that would be nice for videos, but the screen is only mirrored, not controllable from the touch display.

Anybody had any luck in bypassing the double permission dialog prompt from AutoLink upon every single startup? Does HondaHackPro provide any way around this?

Thanks!
Cool. Thanks for the note. I will check this out later this week Is the version you are referring to the Jan 3rd 2019 version? Did you also have to update the box firmware for it to work? Which version of the BOX do you have?
 

·
Registered
Joined
·
84 Posts
Regarding updating the dongle 'box' (the white device that plugs into the left-hand side USB to interface between an iPhone/Android phone) for the AutoPlay, would someone please be kind enough to refresh my memory (bad case of 'brain flatulence') and I can't locate my instructions that I had printed out for myself to follow?


I know arkzrlo has posted the repacked updates, but I can't seem to get the dongle/box to update the interface program with the .img file.


Also, if arkzrlo happens to be reading this, or anyone else that is able to repack and post the updates, may I make a suggestion that when one does provide a repacked .img and .apk file, it might benefit those of us that use this to have a date on the file/folder so we can see what the file date is, making it easier to locate the most current repacked files.

Thanks!
 

·
Registered
Joined
·
12 Posts
Agree with gr8campr. I would also like the repacked updates. Have tried to update the Autoplay app but was unsuccessful but the box updates directly from the interface on the head unit.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #249
Regarding updating the dongle 'box' (the white device that plugs into the left-hand side USB to interface between an iPhone/Android phone) for the AutoPlay, would someone please be kind enough to refresh my memory (bad case of 'brain flatulence') and I can't locate my instructions that I had printed out for myself to follow?


I know arkzrlo has posted the repacked updates, but I can't seem to get the dongle/box to update the interface program with the .img file.


Also, if arkzrlo happens to be reading this, or anyone else that is able to repack and post the updates, may I make a suggestion that when one does provide a repacked .img and .apk file, it might benefit those of us that use this to have a date on the file/folder so we can see what the file date is, making it easier to locate the most current repacked files.

Thanks!
Hi guys,

I try to keep my dropbox folder updated, even if I don't post that I've updated the folder here, the new files should be there within a couple days. (I don't want to spam the thread) You can find the dropbox folder in my signature.

The apk file and de img files in the root folder are always the current updates, previous versions of the firmware and apk are inside the "old" folder.
I tried both img and apk latest files and they worked in my car.
@gr8campr I do not repack the img file, that comes directly from the manufacturer. I remember when I updated mine it was really stubborn to update, but it ended working, maybe try a different usb dongle? not sure what is going on there.
@Naufel can you explain what error you got or why you could not update the apk, I'm assuming you already got a previous version installed, correct?
 

·
Registered
Joined
·
84 Posts
arkzrlo-


Thank you! I understand that, and it is greatly appreciated! Just that I forgot how we update the box, which USB port do we put it into (the one below the dash, left USB port), or the one in the center console?


If I remember correctly, something comes up on the screen to announce that it is working or something?
 

·
Registered
Joined
·
55 Posts
Discussion Starter #252
Thank you for the reply arkzrlo. I have a previous version, repacked by you. I keep getting "The product is not authorized. please contact the dealer" error for the latest firmware.
Are you a 100% the apk you used came from my dropbox folder? There is another apk called AutoKit that does not work with the some of the white dongles. I'm telling you this, because the interface shown on your picture does not match the one on the app I uploaded. I tried the Autokit once on my car and I got the same error when I plugged the dongle to the usb.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #253 (Edited)
arkzrlo-


Thank you! I understand that, and it is greatly appreciated! Just that I forgot how we update the box, which USB port do we put it into (the one below the dash, left USB port), or the one in the center console?


If I remember correctly, something comes up on the screen to announce that it is working or something?
Plug the dongle on the left usb and then plug the usb thumb drive with the img update to the dongle itself. If you do it with the app opened it will show the update process.
 

·
Registered
Joined
·
12 Posts
Are you a 100% the apk you used came from my dropbox folder? There is another apk called AutoKit that does not work with the some of the white dongles. I'm telling you this, because the interface shown on your picture does not match the one on the app I uploaded. I tried the Autokit once on my car and I got the same error when I plugged the dongle to the usb.
I too have tried the Autokit apk unsuccessfully and am now not sure if the error in the picture was from that or the apk from your dropbox folder. However, the December apk does not work for me and the last working one I have is the Novemeber apk.
 

·
Registered
Joined
·
84 Posts
Naufel-

I've been a bit busy, but had some time this morning to mess with things.

This is what I did:


  • Take an older USB flash drive, and make sure that you get anything you want off it (back it up), then format it as FAT (not Fat32, NTFS, etc.)
  • Go to arkzrlo's info in a post (like image shown below), then download the two files from his Dropbox folder, and save them to someplace you will know where they are saved at:
  • I've made a folder on my desktop which I place them in, then insert the USB flash drive and copy the files to the flash drive.
  • Then, go ahead and go to your Pilot, ensure that the Carplay dongle isn't inserted, and either start the engine or use the accessory mode (without foot on brake, push the start button twice).
  • Then, take the USB flash drive and place into the center console USB port and start your Honda Hack pro, then INSTALL APPS (from external storage), and select the Carplay and install.
  • Remove the USB flash drive from the center console port, and then start your Carplay from the head unit screen. Go ahead and place the USB flash drive into the Carplay Dongle and insert that into the LEFT hand USB port on dash.
  • This should then show the update being installed (per arkzrlo's last comment to me).
That worked for me. Hope this helps!
 

Attachments

·
Registered
Joined
·
12 Posts
Naufel-

I've been a bit busy, but had some time this morning to mess with things.

This is what I did:


  • Take an older USB flash drive, and make sure that you get anything you want off it (back it up), then format it as FAT (not Fat32, NTFS, etc.)
  • Go to arkzrlo's info in a post (like image shown below), then download the two files from his Dropbox folder, and save them to someplace you will know where they are saved at:
  • I've made a folder on my desktop which I place them in, then insert the USB flash drive and copy the files to the flash drive.
  • Then, go ahead and go to your Pilot, ensure that the Carplay dongle isn't inserted, and either start the engine or use the accessory mode (without foot on brake, push the start button twice).
  • Then, take the USB flash drive and place into the center console USB port and start your Honda Hack pro, then INSTALL APPS (from external storage), and select the Carplay and install.
  • Remove the USB flash drive from the center console port, and then start your Carplay from the head unit screen. Go ahead and place the USB flash drive into the Carplay Dongle and insert that into the LEFT hand USB port on dash.
  • This should then show the update being installed (per arkzrlo's last comment to me).
That worked for me. Hope this helps!
Thank you, gr8campr for your reply.

I have been using arkzrlo's repacked APK for a while now and glad to say it's been working fine upto now. It's only the last APK (December) which has given me problems.
The Carplay dongle is always updated directly from the headset via wifi when I get notifications to update.
Waiting for arkzrlo to update the latest APK and hopefully that will work.
 

·
Registered
Joined
·
84 Posts
polit_2016-

What that is is that your antivirus program is picking that up as a potential virus. I don't know how legit that is (the virus prompt), however, I had to turn off my Norton Antivirus until I was through doing the download/running the program. I also just ran a complete system scan the other day, and it picked it up and trashed that as well, couldn't get it out of the quarantine.


Hope that helps!
 

·
Registered
Joined
·
29 Posts
Thanks that worked however it says Installation failed after I try to install an app, "Failure [install-failed_internal_error" What is it now????
 
241 - 260 of 341 Posts
Top