Honda Pilot - Honda Pilot Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,653 Posts
Discussion Starter · #1 ·
I was googling for an unrelated term and came across a European blog which contends that the attached pictures show a typical problem of this generation's Pilot engines around 100k miles. I never heard of it. Did anyone have this issue?
 

Attachments

·
Registered
Joined
·
1,653 Posts
Discussion Starter · #2 ·
I scanned other Honda related forums and found a similar problem in the CRV owners' forum as well. It was from a 2002 CRV.
Did anyone ever have this on a Pilot?
 

·
Administrator
2016 CRV Touring AWD, 2005 Pilot RIP.
Joined
·
16,367 Posts
Since the Pilot wasn't sold in Europe (excluding Russia), I question the trustworthiness of your source.
 

·
Registered
Joined
·
1,653 Posts
Discussion Starter · #4 ·
The original Pilot-related forum post was from Russia.
The CRV related post was from the US.
 

·
Registered
Joined
·
190 Posts
Yes it is an issue but i am not sure what years are affected but it seems to be 09-10 J35s. Not sure about europe. My 2009 has a bad camshaft also my 2002 civic si k20 had a bad camshaft.
 

·
Registered
Joined
·
1,653 Posts
Discussion Starter · #6 ·
Great info, thanks!
The original post which I found was regarding the 2012 Pilot.
 

·
Registered
Joined
·
2,573 Posts
the 2012 shares the same engine as the second gen series unless someone upgraded this pilot for the 2015 so what's stopping us from having the same issue ?
 
1 - 7 of 7 Posts
Top