Honda Pilot - Honda Pilot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
On our pilot we had a Honda bug shield put on. We noticed that around 25 to 35 mph the bug shield created a whistle. The dealer replaced the bug shield, but it does the same thing. Has anyone else had this problem with the honda bug shield???:
 

·
Registered
Joined
·
289 Posts
Lots of people

have had this problem. Some Honda dealers will no longer install Honda deflctors until they are changed because of all of the problems with wind noise. Go to the search function at the top of the page and enter "wind deflector". You should get a lot of discussion that you can review. Good luck and welcome aboard.:)
 

·
Registered
Joined
·
2,388 Posts
jakegabe said:
On our pilot we had a Honda bug shield put on. We noticed that around 25 to 35 mph the bug shield created a whistle. The dealer replaced the bug shield, but it does the same thing. Has anyone else had this problem with the honda bug shield???:
I, along with a bunch of people, unfortunately have had this problem with the shield as well. What I would recommend is that you get it uninstalled and get a refund for it. Then get an after market shield from Form Fit or some other trusted companies. Check this link out, http://www.honda-pilot.org/forums/showthread.php?s=&threadid=651&highlight=form+fit

As well, before you get them uninstalled, make sure there are no noticeable scratches, cracks or nicks around the area they drilled holes underneath the hood to install the deflector. If you see any, be sure to mention that to the service dept. and have them properly treat it with clear coat and touch-up paint. Also, check the area after the uninstall too for the same things.

Hope this helps.
 
1 - 3 of 3 Posts
Top