Honda Pilot - Honda Pilot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all,

Hoping to gain some insight and advice about an issue I'm having when using Waze.

Occasionally when using Waze, I'll hear a loud screech and then all audio will cut out (no radio, no bluetooth audio, no USB audio connection). Waze continues to work, as does the Garmin nav, and other display features.

Sometimes shutting the car off and restarting it fixes the problem. But the last couple of times I've shut the car off, the screen remains on. And when the Garmin nav screen is displayed, the map rotates 90deg every second. The last time this happened I had to take the car to the dealer as I was concerned the battery would drain. The dealer rebooted whatever controls the audio/display system and said they didn't really know what was happening but had heard of some incompatibilities between CarPlay and Waze. (Not using Waze isn't a realistic solution or helpful recommendation.)

The problem happened again today and I've got to run the car to the dealer to have the problem fixed. Before I do, hoping to get some thoughts from this group about what could be going on or help me understand if what's happening is unique to my vehicle.

If it makes a difference, I have a 2019 Pilot Elite.

Many thanks!
 

·
Registered
Joined
·
42 Posts
In your Waze settings go to "Voice & Sound" and turn off "Show audio player". I had similar problems on my '19 EX and they went away after I turned it off.
IMG_C372D3163FC4-1.jpeg
 
1 - 3 of 3 Posts
Top