Honda Pilot - Honda Pilot Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
My alternator went belly up on my last RV trip. $440.00 later I got it back with a re manufactured one obtained at Autozone. On the drive back,...Fla to Vt. I noticed the battery light coming on once in a while, just a quick flash. Never failed to start, but I'm wondering if this could be a bad alternator , or dirty battery / electrical connections? Thoughts?
 

·
Registered
Joined
·
138 Posts
I would check to make sure the main power cable to the alternator is tight, then clean the battery posts and cable terminals (this should have been done during the alternator install). Also remove the ground cable from the radiator support and wire brush it clean along with the bolt and the mount area. If it still happens I'd take it to Autozone and have them do a check.
 

·
Registered
Glorificatus Oleum Mutante
Joined
·
12,296 Posts
Also remove the ground cable from the radiator support and wire brush it clean along with the bolt and the mount area.
141736
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
4,360 Posts
The failed alternator may have placed some strain on the battery. Have the battery tested, in addition to what was mentioned above.
 
  • Like
Reactions: Nail Grease

·
Registered
Joined
·
341 Posts
I've been working on all parts of my car and today while cleaning the MAF sensor/replacing the cracked air hose airbox-to-manifold/installing new air filter, I noticed the pulley on the alternator I installed a few weeks ago is pretty obviously not precisely in line with the rest of the accessory pulleys. Everything is working fine, the new belt looks fine, everything seems ok, but that pulley is tilted toward the back of the car enough it makes me nervous

I'm embarrassed but I want to get a look at another 2009 and see how perfect all the pulleys are. And the hardest part of swapping the alternator was jamming the new one into the mounts/brackets and getting it lined up for the bolt to insert/thread smoothly. So I can't imagine it's anything other than poor manufacturing of an aftermarket part, hahaha, which I've been saying I'm not scared of since the original only lasted 149k miles anyway! hahaha. I didn't knock on wood enough, apparently.

Anyone remember a thread somewhere or know of an issue with alternator pulleys not lining up? especially with the highest quality piece from O'Reilly?
 
1 - 5 of 5 Posts
Top