Honda Pilot - Honda Pilot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My 2019 Pilot (no navigation) had the clock recall completed then shortly after the clock repair would return to 7pm and 2015 every time I started the car. I also had the light on for no GPS connection, nor could I connect via wireless and thus could not do system updates. Brought to the dealership and after keeping it for a day stated they needed it for longer diagnosis as they had no idea what was wrong...however I was leaving on vacation so promised to bring it back upon return. I tried doing a full default setting reset, no luck. After reading several threads here on Piloteers and google, I tried pulling fuses #29 (radio) and #26 (back-up) under the hood in engine fuse box A. I waited about 10 minutes and then replaced with the same fuse. Started the vehicle, was prompted to depress and hold the radio button for 2 seconds and after it reset, it was fixed! Immediately had the right time, right date, gps connected, wireless connected allowing for updates. Also checked the car the next morning, all good. Can't explain why, but it worked. Hope it helps.
 

·
Registered
Joined
·
9,349 Posts
My 2019 Pilot (no navigation) had the clock recall completed then shortly after the clock repair would return to 7pm and 2015 every time I started the car. I also had the light on for no GPS connection, nor could I connect via wireless and thus could not do system updates. Brought to the dealership and after keeping it for a day stated they needed it for longer diagnosis as they had no idea what was wrong...however I was leaving on vacation so promised to bring it back upon return. I tried doing a full default setting reset, no luck. After reading several threads here on Piloteers and google, I tried pulling fuses #29 (radio) and #26 (back-up) under the hood in engine fuse box A. I waited about 10 minutes and then replaced with the same fuse. Started the vehicle, was prompted to depress and hold the radio button for 2 seconds and after it reset, it was fixed! Immediately had the right time, right date, gps connected, wireless connected allowing for updates. Also checked the car the next morning, all good. Can't explain why, but it worked. Hope it helps.
Lol, Amazing you figured it out but they couldn't.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
It was a collective effort from info on previous threads... and luck. Hoping the fix will last the duration. I’ll provide an update if it doesn’t! 😊
 
1 - 3 of 3 Posts
Top