Honda Pilot - Honda Pilot Forums banner

2018 pilot broke down 3 times in month with code p2652 rocker arm

861 4
Hi everyone! This is the third time my car is broken down this month for the same problem!! It starts with check engine light and emissions system problem and the car shakes even when in park, when I try to accelerate there’s hardly any power to go. Had it towed to Honda as it’s under warranty. They said the rocker arm pressure switch needed replaced. Picked it up and TWO days later it happened again! So it got towed back to Honda where they diagnosed it as a faulty switch they replaced the first time. Okay, it got replaced and picked up 4 days later which seemed a bit much if it was just replacing faulty switch. So now yesterday it happened for the 3rd time!! Has this happened to anyone else?? Has it been replaced and kept breaking down and it’s the same dang code!!??
please let me know if anyone has suggestions! Thanks so much
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Looks like the whole assembly will have to be replaced instead of just the switch.
Well; that sucks!! Should I suggest thst to the advisor at Honda I mean it’s the third time in less than a month, that seems a bit much. I don’t know about cars but if it keeps happening I would assume to look past what the code reader is saying. The first time it happened was after I got gas from a station near home & some of the gas got on my foot and it didn’t smell as strong as it usually smells so my husband and I both thought maybe bad gas?? But I’ve gotten gas from different station since and it ran fine for all of 9-11 days and happened again so I guess not the gas??
 

· Registered
Joined
·
49 Posts
Hi everyone! This is the third time my car is broken down this month for the same problem!! It starts with check engine light and emissions system problem and the car shakes even when in park, when I try to accelerate there’s hardly any power to go. Had it towed to Honda as it’s under warranty. They said the rocker arm pressure switch needed replaced. Picked it up and TWO days later it happened again! So it got towed back to Honda where they diagnosed it as a faulty switch they replaced the first time. Okay, it got replaced and picked up 4 days later which seemed a bit much if it was just replacing faulty switch. So now yesterday it happened for the 3rd time!! Has this happened to anyone else?? Has it been replaced and kept breaking down and it’s the same dang code!!??
please let me know if anyone has suggestions! Thanks so much
Years ago I had a similar issue with a vehicle. The problem turned out to be a faulty electrical connection at the plug that connects to the computer. The dealer ended up using a special tool to replace the female connecter. I hope your problem is easier to diagnose. It took me a year and a half and several trips to different shops to find the problem.
 
1 - 5 of 5 Posts
Top