Honda Pilot - Honda Pilot Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Went for a 1 week cruise and left my 2016 pilot inside the garage. Upon my return, I drove out my pilot and found out the speedometer gauge disappeared. I drove it around the block and the speedometer DIDN'T WORK AT ALL. In other words, I couldn't tell how fast I am driving. I brought it to autonation honda in Fremont, CA. The Honda mechanic didn't find anything wrong with the speedometer but don't know why it won't work! The dealership decided to replace the whole speedometer gauge and I had to leave my car for a few days.
Anyone out there experience this?
 

·
Registered
Joined
·
83 Posts
No experience here; but, interested in your results. Did replacing the cluster fix the problem?
 

·
Registered
Joined
·
6 Posts
Went for a 1 week cruise and left my 2016 pilot inside the garage. Upon my return, I drove out my pilot and found out the speedometer gauge disappeared. I drove it around the block and the speedometer DIDN'T WORK AT ALL. In other words, I couldn't tell how fast I am driving. I brought it to autonation honda in Fremont, CA. The Honda mechanic didn't find anything wrong with the speedometer but don't know why it won't work! The dealership decided to replace the whole speedometer gauge and I had to leave my car for a few days.
Anyone out there experience this?
Ironically I have had the same issue, since November 2018. It has been pretty sporadic, until last Sunday (4/28). It has now been off for over a week. Just the speedometer, nothing else. Took it to the local dealership in December. They said I have a glitch in my "gauge cluster". Not covered because it is not under warranty nor is it a "safety issue" (I beg to differ). I called the Honda Customer Care line the other day, just as the dealership did in December, and had them document my issue. They told me to work with my local dealership to get it resolved. Did the dealer cover the cost? What exactly did they replace? Sounds like this issue has happened to more than one (me) person. All Honda has to do is do a quick search and they will find a hand full of us with this issue. That's how I found you all. Thanks for sharing your Pilot issues!
 

·
Registered
Joined
·
6 Posts
This just happened to me. Did you find a fix?

Sent from my ONEPLUS A6003 using Tapatalk
Ironically I have had the same issue, since November 2018. It has been pretty sporadic, until last Sunday (4/28). It has now been off for over a week. Just the speedometer, nothing else. Took it to the local dealership in December. They said I have a glitch in my "gauge cluster". Not covered because it is not under warranty nor is it a "safety issue" (I beg to differ). I called the Honda Customer Care line the other day, just as the dealership did in December, and had them document my issue. They told me to work with my local dealership to get it resolved. Sounds like this issue has happened to more than one (me) person. All Honda has to do is do a quick search and they will find a hand full of us with this issue. That's how I found you all. Thought I'd share my experiences with you directly as well. Thanks for sharing your Pilot issues!
 

·
Registered
Joined
·
12 Posts
Still happening to me.

It seems to be more finicky when it's colder or during dramatic changes in temperature. Pretty dumb.


Sent from my ONEPLUS A6003 using Tapatalk
 

·
Registered
Joined
·
6 Posts
Still happening to me.

It seems to be more finicky when it's colder or during dramatic changes in temperature. Pretty dumb.


Sent from my ONEPLUS A6003 using Tapatalk
If it's still happening, call your local dealership, so they can find out what's really wrong and document it with Honda. Just dropped mine off, 2nd time since December, for them to really diagnose it and contact Honda. I'm the first case they've encountered. Let me know what you find out. You should also contact Honda Customer Care, so they can document it too. I'm going on 2.5 weeks without a working speedometer.
 

·
Registered
Joined
·
618 Posts
Haven’t had this happen yet but the thing that really sucks Is when they replace it the odometer will be at 0 and they will have to put a sticker on the door. Might be easier to just find one with close mileage and replace without them knowing. But of course then tif the issue becomes widespread as it seems it is they won’t issue recall or TSB.

Boy seems like Honda dropped the ball on these newer pilots!
 

·
Registered
Joined
·
62 Posts
The mileage should convey over to the new cluster if done by the dealer. That was only really an issue with the old mechanical odometers.

Sent from my Pixel 3 using Tapatalk
 

·
Registered
Joined
·
618 Posts
The mileage should convey over to the new cluster if done by the dealer. That was only really an issue with the old mechanical odometers.

Sent from my Pixel 3 using Tapatalk

A lot of the digital odometers only store the mileage in cluster and can be calibrated to the correct mileage but thats mostly done by an outside company. Most of the ones Ive seen done they just replace it at zero and put a sticker on the door. did that at the Toyota dealer I worked for and when my wifes subaru was having an issue with the speedometer they said it would be at zero when replaced... ended up just selling the car anyway. That was a 17 impreza.
 

·
Registered
Joined
·
6 Posts
Haven’t had this happen yet but the thing that really sucks Is when they replace it the odometer will be at 0 and they will have to put a sticker on the door. Might be easier to just find one with close mileage and replace without them knowing. But of course then tif the issue becomes widespread as it seems it is they won’t issue recall or TSB.

Boy seems like Honda dropped the ball on these newer pilots!
In my case, Honda will only help a little with cost of new gauge cluster, as it is out of warranty. I say, fix mine free of charge so you don't end up having to fix millions in a recall or service bulletin. Gotta love technology! And, the dealership will do all the calibration on the new cluster. Don't think they put that sticker on anymore. I do suggest that if anyone out there is having any speedometer issues, to please contact your local dealership (whether it's still under warranty or not) AND the Honda Customer Care line. They need to know how serious this is! Good luck to everyone!
 

·
Registered
Joined
·
20 Posts
I was driving my 2019 Touring (purchased 1 month ago) today and the entire dashboard along with the radio went out for a few seconds and then it popped back on. Everything went black and the sound turned off. I hope it was just a fluke.
 

·
Registered
Joined
·
20 Posts
I was driving my 2019 Touring (purchased 1 month ago) today and the entire dashboard along with the radio went out for a few seconds and then it popped back on. Everything went black and the sound turned off. I hope it was just a fluke.
 

·
Registered
Joined
·
171 Posts
I was driving my 2019 Touring (purchased 1 month ago) today and the entire dashboard along with the radio went out for a few seconds and then it popped back on. Everything went black and the sound turned off. I hope it was just a fluke.
We've had our '16 Touring for three years and I've never experienced this but just recently my wife told me that this has started happening to her a few times when the idle stop turns the car off. I always shut off that feature when I drive it so maybe that is why it hasn't happened to me. Like I said, the Pilot is three years old. Could this be an early indicator that the battery is beginning to fail? If so, I'm not sure why your 2019 would be experiencing this already. :confused:
 

·
Registered
Joined
·
3 Posts
Went for a 1 week cruise and left my 2016 pilot inside the garage. Upon my return, I drove out my pilot and found out the speedometer gauge disappeared. I drove it around the block and the speedometer DIDN'T WORK AT ALL. In other words, I couldn't tell how fast I am driving. I brought it to autonation honda in Fremont, CA. The Honda mechanic didn't find anything wrong with the speedometer but don't know why it won't work! The dealership decided to replace the whole speedometer gauge and I had to leave my car for a few days.
Anyone out there experience this?
Mine went out and I used my phone for speedometer until inspection required it. Then hubby decided to look into it and replaced the instrument cluster and it now works. Only downside is the odometer is located in the cluster so we had to make sure and note the previous mileage.
 
1 - 20 of 20 Posts
Top