Honda Pilot - Honda Pilot Forums banner
1 - 6 of 6 Posts

·
Registered
2016 Honda Pilot EX-L AWD
Joined
·
31 Posts
Discussion Starter · #1 ·
Went to install the Tekonsha P-3 after waiting what seems like forever on back order to get it. Finally was instock at etrailer got it about 2 weeks ago. Got the 3070-P adapter from Amazon as I had forgotten to order it with the P3 from etrailer. The problem now is that when I plug into the wiring in the car, the Controller doesn't turn on. I took a power tester to probe the wires on the car and didn't get any lights (I tested on different plug and they do light up just so I know my probe is working right). What can I do at this point?

I am taking the car into dealership for oil change on Tuesday. would they take a look an fix if I mention it?
 

·
Registered
Joined
·
106 Posts
Forgive what might sound like a silly question, but did you get the trailer wiring kit installed? There's more than just the pigtail that plugs in under the dash. There is a fuse block that gets installed in the left rear, there are additional fuses and relays that get installed in the fuse block under the hood.
 

·
Registered
2016 Honda Pilot EX-L AWD
Joined
·
31 Posts
Discussion Starter · #4 ·
Forgive what might sound like a silly question, but did you get the trailer wiring kit installed? There's more than just the pigtail that plugs in under the dash. There is a fuse block that gets installed in the left rear, there are additional fuses and relays that get installed in the fuse block under the hood.
not a silly question.. I should have stated it.

The towing kit and trailer wiring was already installed when I purchased the car and it was factory installed (not sure as I purchased second hand). I assumed that everything else (fuse/relays) should have been installed. I guess I need to see if there was anything missed.
 

·
Registered
2016 Honda Pilot EX-L AWD
Joined
·
31 Posts
Discussion Starter · #5 ·
You'll need one of these:

Trailer Hitch Harness

It's a bit simpler than the one I installed in my 2015, but there are still relays and fuses that get installed.
Well, looking at the install guide.. it did help as I found that the E-Brake assist Fuse was not installed. I plugged the spare from the main fuse box and low and behold.. it's getting power..

Next question. I noticed there is a fuse for FR De-ice which is missing as well. what does this control and do I need it?!
 

·
Registered
Joined
·
1,045 Posts
Well, looking at the install guide.. it did help as I found that the E-Brake assist Fuse was not installed. I plugged the spare from the main fuse box and low and behold.. it's getting power..

Next question. I noticed there is a fuse for FR De-ice which is missing as well. what does this control and do I need it?!
Only if your Pilot came with the windshield de-icing option installed. Otherwise, you leave it empty.
 
1 - 6 of 6 Posts
Top