Honda Pilot - Honda Pilot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi everyone

I am hoping someone can help me. My 2012 Pilot EX has approximately 126,000 miles and today when I was driving the Check Engine, VTM-4, VSA and Maintenance Minder Lights all went on at the same time. None of them are blinking - they are all solid and they come back when I turn on the car. I know that I need an oil change but this seems to be a bigger problem. I am wondering if 1) anyone has had this happen and what the outcome was and 2) is it safe to drive or do I need to have it towed? I was hoping to trade it in for a newer model but it looks like I need a new plan. Thank you in advance for any advice.
 

·
Registered
Joined
·
241 Posts
Hi everyone



I am hoping someone can help me. My 2012 Pilot EX has approximately 126,000 miles and today when I was driving the Check Engine, VTM-4, VSA and Maintenance Minder Lights all went on at the same time. None of them are blinking - they are all solid and they come back when I turn on the car. I know that I need an oil change but this seems to be a bigger problem. I am wondering if 1) anyone has had this happen and what the outcome was and 2) is it safe to drive or do I need to have it towed? I was hoping to trade it in for a newer model but it looks like I need a new plan. Thank you in advance for any advice.
Usually when you get multiple lights it is a sign of a power issue. Check for a weak battery or alternator. Also check for codes.

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
2,551 Posts
Too bad Honda never thought of the volt gauge ..i miss that from my tahoe and Suburban
 

·
Registered
Joined
·
853 Posts
It's your battery, replace it.

Folks say "have it tested" but my experience they will test well even though they are on the way out. For instance, my battery started showing signs of failure, random lights, jump starts. But the dealer said it tested fine, on several occasions. Finally after three or four months of this it finally died. Just replace it.
 
1 - 4 of 4 Posts
Top