Honda Pilot - Honda Pilot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Been trolling the internet now for several weeks and not getting any specifics hits on the issue.. Thought I would try the forum here...

Just a few weeks ago my 2011 Honda Pilot started throwing the following codes.. although NO Check engine light or really no performance changes..

I do have my OBD reader on full time, hence I picked up the codes.. I do believe I'm also seeing some slight gas mileage decrease.. I usually get around 19.2 miles around town.. .Now getting approx 16.8..

I've tried resetting the codes several times.. I've purchased the car 2014. with 70k. Currently has 140k miles.. I've changed the oil religiously, less than 5k per change.. 5-20w..

Codes:
C1555 Chassis
P0962 Powertrain
P0966 Powertrain
P0970 Powertrain
P2649 Powertrain - A Rocker Arm Actuator Control Circiut High Bank1
P2654 Powertrain - B Rocker Arm Actuator Control Circuit High Bank1
P2659 Powertrain - A Rocker Arm Actuator Control Circuit High Bank2

Any Ideas?

I presume these are all possibly related to a single issue?

I appreciate it!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Thanks Rocky for the prompt response.. I believe I did find that link earlier on too..

What's throwing me is that I believe there are two rocker arm actuators.. One listed on the driver side(back firewall side) and second one on the passenger side(timing belt side)..

What's the probability that they both went bad? I think that is a slim chance..

The engine oil is at the correct level.. I did go ahead and change the oil again, with another new filter.. since it did occur since the last oil change...

I haven't made any changes to the oil type or filter in the past couple years.. using Mobile 1 synthetic 5-20w..


Another thing throwing me.. is that the check engine light is NOT on...

I'm not fully informed on how this VTEC system fully works, although I do understand the concepts.. Could it be in any way just related to a faulty engine oil pressure switch? Not sure if that is referenced in the VTEC sensors...

I just did get the recall notice on the passenger side airbag.. so will be visiting the dealer soon... but.. I really don't like other people working on my car.. finding I'm paying top dollar for shoddy work... even at a dealer... besides the fact they could be damaging my car further...

thanks again for your help... as I continue to troll thru the internet and try to find answers...
 

Attachments

·
Registered
Joined
·
130 Posts
They all share ground g101 which is one of the passenger side grounds on the engine. But a lot of other things share that ground as well.
It is very strange that you received all of these codes. There are 3 rocker arm solenoids 2 rear, 1 front. So have 3 solenoids go bad just doesn't make sense.

I would start with battery connections and grounds. Check all fuses. The troubleshooting for each of these is ohm out solenoid then check ground.

Possible PCM.


Is there anything that happened to the vehicle ? ( backwards jumper cables, new alternator, high water??)
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
thanks jochute, much appreciated..

I agree.. Your line of thought is exactly what I'm thinking a ground issue.. or possibly the PCM...

No changes or service to the Vehicle in the past 6 mos or so.. I did have the timing belt done over a year ago.. and last spring, the timing belt tensioner came loose, so they had to readjust that.(glad I caught that one quickly)...

I think the easiest thing to do is to check for good ground on the block and at the actuators.. and work it back from there..

I do have my muti meter ready!!

I did just schedule my passenger airbag replacement for Friday.. so if I haven't found any clues.. I'll let the dealer check it out..

I'll keep the forum posted of my results..

Cheers!!

fyi.. i did notice some of the other codes I had listed.. seemed to point to transmission actuators... ..if i understood those correctly..
 

·
Registered
Joined
·
130 Posts
A faulty engine oil pressure switch will give you a dash light. The manual calls this the rocker arm oil pressure switch but its the engine oil pressure switch. The other codes are transmission solenoids A,B, and C.

I would start with the easiest connector the front rocker arm solenoid, pull off connector and ohm sensor = 13.9-16.9 ohms pins 1-2. Then check connector pin 2 ( I would remove the PCM so you don't send voltage to it accidentally) to battery NEG. You should 0-1 ohms. If it is above this, a ground is bad. If this ground check is bad I would assume that is your problem for all the codes.
 

·
Registered
Joined
·
130 Posts
Pin 2 on the connector goes to ground g101. So with one meter lead to pin 2 and one on the battery Neg you should get less than one ohm.

What are you reading? You really need to figure out g101, clean that ground and then check from g101 to NEG.

There is no way to check PCM except for output voltages.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
thanks Jochute for all your help.

Just came back from the dealer last nite...

The called and said the oil sensors are bad and replaced both of them... I'm thinking..how could both gone bad at same time..

Anyways.. they replaced both, and now the rocker arm codes are gone..

They claimed they weren't seeing the transmission codes.. but they did come back on by the drive home...

P0962
P0966
P0970
C1555 - Chassis ??

So now onto replacing these three also?

I still think there's possibly some other underlying issue.. All five of these went bad at the same time?

No work at all prior to the failure of these five.. Timing belt was done over a year ago.. I've driven a good 15k since then, error free..

Only thing that did change in that period..is I unconsciously, changed oil weight from 5-20w to 0-20w.. and started using a different brand oil filter.. the oil i use is mobile 1 synthetic...
 

·
Registered
Joined
·
130 Posts
Not sure what you had to pay for the sensors but those codes are p3400 p3497 for rocker arm pressure switches. Not sure about the transmission codes i would have to look into it.
 

·
Registered
Joined
·
6 Posts
Did you ever resolve the other codes P0962 P0966 P0970 C1555. I have the same codes. Even tried a junk yard ECU still same codes.
 
1 - 11 of 11 Posts
Top