Honda Pilot - Honda Pilot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
After two nights of rain, today the Brake Lamp cluster indicator came on.

I checked all the bulbs and the only lights I found to be not working are these little ones on each side of the front.


All the other lights and turn signals work.

Has anyone else had an issue with the indicator coming on, even when all lights work?
-brake lights (3 bulbs, one on each side bottom, plus one in the spoiler over the hatch)
  • turn signals, and hazards
  • parking lights on the fenders, rear parking lights (two bulbs each side)
  • high beams,
  • low beams, etc

Does anyone know when these front top corner bulbs should come on?
 

·
Registered
Joined
·
6,235 Posts
Can't hurt to try to replace those bulbs, but check fuses first, just to be sure.

When one of those side marker bulbs went out on mine, it was on the driver's side and it was awkward and frustrating to get into that little corner with my fat fingers. And I foolishly thought I could do it quickly outdoors in winter, so my fingers froze but my choice words were hot.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #3
Can't hurt to try to replace those bulbs, but check fuses first, just to be sure.

When one of those side marker bulbs went out on mine, it was on the driver's side and it was awkward and frustrating to get into that little corner with my fat fingers. And I foolishly thought I could do it quickly outdoors in winter, so my fingers froze but my choice words were hot.
Thanks for the comments and warnings. It’s supposed to be 60 degrees and sunny here tomorrow. So I will wait. I remember always being frustrated trying to replace headlights on this car.
 

·
Registered
Joined
·
29 Posts
Mine comes on sometimes when it's wet out, but always goes back out on it's own. Sorry I am not much help but I am following this thread to see your outcome.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #5
Mine comes on sometimes when it's wet out, but always goes back out on it's own. Sorry I am not much help but I am following this thread to see your outcome.
Maybe that’s exactly what our issue was. The brake lamp indicator is not on now. Interesting. Thank you for this new explanation.
 
1 - 5 of 5 Posts
Top