Honda Pilot - Honda Pilot Forums banner

1 - 20 of 37 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
The check engine light on My '06 pilot will flash with the first start-up of the day, after that is just stays on, no flashing. Sedolmy, the VTM-4 light will come on. Driving is smooth with no issue, all issue are at the initial start up and causes the vehicle yo vibrate. I got misfire codes and replaced all the spark plugs, but still having an issue.
Any thoughts would be appreciated!
 

·
Registered
Joined
·
207 Posts
Oil level and pressure are good? If so, might be time for a valve adjustment.
 

·
Registered
Nobili spiritus embiggens pequeño sparus tyre.
Joined
·
9,275 Posts
...get an OBD2 code scanner/reader .. many can be bought for under $30 ...
Yes, definitely get your codes read and post them here before just guessing. Best is to buy one, which it will always be useful to have, but otherwise some of the big chain auto parts stores will read them for you for free.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
139425
these are the codes I'm getting since replacing the spark plugs and a coil pack.
 

·
Registered
Nobili spiritus embiggens pequeño sparus tyre.
Joined
·
9,275 Posts
Where did you get your spark plugs? (There are some fakes out there, on Amazon and elsewhere.)
 

·
Registered
Nobili spiritus embiggens pequeño sparus tyre.
Joined
·
9,275 Posts
Who installed them? Were they torqued to spec?

Have you ever changed the PCV valve? It's inexpensive.

How about cleaning or replacing the EGR valve? And cleaning the EGR passages?

Maybe it does need a valve adjustment, but perhaps try those less expensive solutions first. Maybe even try to run some Seafoam through. You may well be pleasantly surprised.

 

·
Registered
Joined
·
13 Posts
Discussion Starter · #10 ·
My husband does most of the mechanical work on it, as he does in all our vehicles. I did run a fuel treatment and had thoughts about the PCV valve or the crankshaft sensor, but I'm not getting a code for either of those. Could they still be causing an issue?
 

·
Registered
Nobili spiritus embiggens pequeño sparus tyre.
Joined
·
9,275 Posts
Hard to say, but try all the above suggestions, as they are relatively inexpensive. What fuel treatment? Any recent work by your husband before this happened?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #12 ·
Just purchased and problems happened about a week after driving. He hasn't done anything besides the spark plugs. I used an Acdelco fuel treatment.
 

·
Registered
Nobili spiritus embiggens pequeño sparus tyre.
Joined
·
9,275 Posts
Two Occam's Razors jump up.
  1. Previous owner hid something. Did you get the vehicle inspected by a trusted mechanic prior to purchase? If not, maybe do it now. Better late than never.
  2. Give the ACDelco stuff a few weeks to dissipate and go away, hopefully. Then try the above steps and if you do use a fuel treatment, use Seafoam.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #14 ·
I took it to a mechanic and now they can't seem to find what the issue would be; they had it in the shop for the day. They recommended the fuel treatment b/c they couldn't find what another issue would be. I've got an apt next week with a different mechanic to see if he might find something else. Just trying to narrow it down before I get it there.
I appreciate your responses
 

·
Registered
Joined
·
526 Posts
How about cleaning or replacing the EGR valve? And cleaning the EGR passages?
I took it to a mechanic and now they can't seem to find what the issue would be; they had it in the shop for the day. They recommended the fuel treatment b/c they couldn't find what another issue would be. I've got an apt next week with a different mechanic to see if he might find something else. Just trying to narrow it down before I get it there.
I appreciate your responses


Try this EGR test/fix, takes under 10 minutes,
Carburetor cleaner-spray is about $4 at Autozone , and an old toothbrush.
*EGR Gasket is $3~ , if needed
You will need a 12mm socket to remove the EGR
 

·
Super Moderator
2020 Honda Passport Touring AWD Metallic Steel
Joined
·
4,277 Posts
If the above two suggesting don't work consider having a professional combustion system cleaning procedure done. Honda has a system. Don't know what it costs. The system I have used is BG. I live in the city that BG headquarters and production facility is located and have been in their demonstrator vehicle system for several years.

I have a 19 year old 3/4 ton PU that is my towing vehicle. It has had the BG system for 16 years. The truck has been a work horse and still has the power it always had. Never had a combustion system problem.
 

·
Registered
Joined
·
14 Posts
I got a lot of the same codes as you and it was recommended to change the EGR valve. I tried cleaning it first but that didn’t work. I ended up getting one on eBay for less than $30. Autozone wanted around $80. That did the trick and engine light went out. It came back on a day later but then went out the next day and had been out for over a month now. I got an OBD reader about the same time so now I read my own codes.
 

·
Registered
Joined
·
207 Posts
all issue are at the initial start up and causes the vehicle yo vibrate.
The shaking at start-up, coupled with the the random P300-306 DTCs, suggests (to me) the exhaust valves are too tight and causing issues when cold.

Cleaning the EGR ports and changing the EGR valve are cheap and relatively quick, but I don't believe the EGR system will cause engine vibration/shaking...
 
1 - 20 of 37 Posts
Top