Honda Pilot - Honda Pilot Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
When it starts idles really rough, and when i put it in gear it dies unless its completely warmed up, check engine light and vtm-4 are on and blinking it says all my cylinders are misfiring, also its smells like antifreeze pretty bad, I need help.....
 

·
Registered
Joined
·
2,551 Posts
codes ?
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
2,971 Posts
Does the exhaust smell like antifreeze/coolant?
 

·
Registered
Joined
·
2,551 Posts
Does the exhaust smell like antifreeze/coolant?
Might be a head gasket but without knowing the miles or anything ..it's a toss up
 

·
Registered
Joined
·
2,551 Posts
I have the same 06 with 4k miles more than you I just went through this nightmare with the p0172 /175 .
I changed out the injectors tested my 02 sensors nothing code still sprung .. same issue wont move till warmed up ..found out that the EGR valve it's 200 bucks but it's designed in a way that the aftermarket ones will not work properly it's a hit and miss with them .. solved the p0172/175 ..now for the coolant when was the last time you replaced the timing belt with the kit ? that also involves the water pump ..it sounds like your pump is seriously failing if your smelling coolant ..do a visual underneath ..if the pump is indeed leaking you will see a lot of coolant moisture in the passenger side of the bottom side of the engine. Also if the water pump is leaking it will cause havoc with the timing belt so that may cause the p0300-06 codes .. If you can smell coolant / sweet smell in the exhaust like road2cycle suggested good chance you have a blown head gasket. I know other will chime in with advice there are a lot of great knowledgeable people here ..best of luck ..
 

·
Registered
Joined
·
2,551 Posts
No .. The EGR valve is shot
 

·
Registered
Joined
·
2,551 Posts
How can u tell that its shot?
There should be little to none movement to that center piece . on mine I could not get it to move ..so if yours is easy to move then it's beyond its life cycle.
 

·
Registered
Joined
·
2,551 Posts
Did you have someone take a look at this Pilot a shop for instance and your just trying to fix this yourself ? There are other ways mechanics can diagnose and determine what the cause is without ripping out part by part to fix the issue :)
 

·
Administrator
Joined
·
15,526 Posts
When my EGR went, I just replaced it with another from my local NAPA. It's been 100% fine since then. About $75
 

·
Registered
Joined
·
5,649 Posts
When my EGR went, I just replaced it with another from my local NAPA. It's been 100% fine since then. About $75
What were your symptoms?
 

·
Administrator
Joined
·
15,526 Posts
Bad idle. Drove ok at speed
CEL
kid calling from 100 miles away.
On a Saturday of a Holiday weekend.
I guessed bad EGR, bought one before store closed. Drove down to "rescue" it and swap cars. Took a ton of patience and PB blaster before I could squeeze my fat fingers in there and loosen the nuts.
as soon as new unit bolted and plugged in, car started and idled perfectly.
 

·
Registered
Joined
·
2,551 Posts
Purchased an EGR valve from rockauto ..lasted 4 months before the codes came back took a hit purchased an OEM egr valve and the bugger has been smooth sailing since … no idle / rough running issues
 
1 - 17 of 17 Posts
Top