Honda Pilot - Honda Pilot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2005 Honda Pilot EX. We just replaced the alternator and radiator and now the heat controls will not work at all. They don’t even turn on. About a week ago, the issue started. First, it would blow heat from the back floor vents even with no controls on and now there is nothing. Cold air that I cannot shut off. I live in Colorado and the weather in December is not cool to have no heat. Also, the sun sensor isn’t working either. We’ve checked and replaced the fuses, tightened the heater control valve screw. Any other suggestions on what it might be? Other than the heater core. Any help is appreciated. TIA!! :)
 

·
Super Moderator
Joined
·
15,156 Posts
If the control unit is responding to your commands let's go with that being ok. There is a little valve in the engine bay that can get loose on some cars over time. It's right up by the bulkhead.
Follow the coolant hoses to it.
 

·
Registered
Joined
·
1,766 Posts
Are the front and rear blowers working?
The blower motor transistors are known to fail.

Do you hear the air mix flaps move when you change the settings from hot to cold?

Or are you saying the climate control panel is not powering? I have an LX so my panel is different so maybe this is an incorrect question.
 

·
Registered
Joined
·
1,766 Posts
Also did you fully burp the air out of the cooling system after the radiator was replaced? You may have an air pocket trapped on one or both heater cores.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5 (Edited)
The cooling system was fully burped out after replacing the radiator. It’s almost like there is no power to the heater controls. The little screen isn’t coming on at all and none of the lights. However, the stereo and everything else right there is working just fine. Both fans and the blower are working, too.
 

·
Registered
Joined
·
1,766 Posts
If you already replaced the relevant fuses I wonder if it would be worthwhile to pull the module out and verify the wiring harness and wiring is intact.
Had any work been performed on the Pilot prior to the issue occurring? Any recent rodent infestations?
 

·
Registered
Joined
·
1 Posts
Is just temp not working or no air or mode control either? I just replaced the blend door motor in my 2006 due to no heat; but fan speed and direction of air was working fine.
Online new part aftermarket part $310, U-Pull price $4.55... effort 15 minutes each to remove & install
 
1 - 8 of 8 Posts
Top