Honda Pilot - Honda Pilot Forums banner
21 - 31 of 31 Posts

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
4,251 Posts
This is that PCB I was thinking about. If it’s easy to get to it couldn’t hurt to take a look.
 
  • Like
Reactions: ccbcc

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
4,251 Posts
What temp readings do you get if you set cabin temperature to highest? What about at coldest? Let the temperature stabilize before taking the readings.
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
4,251 Posts
All i did:

1.changed blend door actuators
2. moved blend doors by hand to make sure they move smoothly
2.changed heater core
3. Check for air leak in interior ducts
4. changed radiator cap
5.changed thermostat
6. changed water pump
7. changed blower fan, cabin filter & blower fan resistor
8. Got a used climate control unit and swapped in out to test if mine was bad
9. Did self diagnostic test no dtc's

After all of this I am still unable to control the temperature of the heat from the climate control unit. I only get either max heat or max cool. Actuators should move gradually as I adjust the temperature on the climate control unit?
Not sure if it would affect things, but have you verified the rear blower spins? It’s located under the center console?

Your list is quite comprehensive. That’s a lot of parts which were changed out.

You also changed out the heater core valve that @plplplpl mentioned, right?
 
  • Like
Reactions: plplplpl

·
Registered
Joined
·
18 Posts
Not sure if it would affect things, but have you verified the rear blower spins? It’s located under the center console?

Your list is quite comprehensive. That’s a lot of parts which were changed out.

You also changed out the heater core valve that @plplplpl mentioned, right?
Yes, heater valve was changed.
 

·
Registered
Joined
·
18 Posts
This is that PCB I was thinking about. If it’s easy to get to it couldn’t hurt to take a look.
This is that PCB I was thinking about. If it’s easy to get to it couldn’t hurt to take a look.
I had went to the dealer and had gotten brand new air mix motors for driver & passenger side and installed them. Problem still exists...
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
4,251 Posts
When you replaced the climate control module did you check the wiring harness(es) which connect to it. Any loose connections, corrosion, oxidation, etc.?
 
  • Like
Reactions: plplplpl

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
4,251 Posts
Max heat - 153
Max cool - 44
I should have specified what does the climate control report for the two extreme cases. Similar to the four parameters you listed before.
Your results prove the system is capable of reaching full hot and full cold.🥵🥶
 

·
Registered
Joined
·
18 Posts
When you replaced the climate control module did you check the wiring harness(es) which connect to it. Any loose connections, corrosion, oxidation, etc.?
Yes i checked for continuity and good ground through out the harness. All connections were good
I should have specified what does the climate control report for the two extreme cases. Similar to the four parameters you listed before.
Your results prove the system is capable of reaching full hot and full cold.🥵🥶
exactly I am just unable to control the cabin temperature
 

·
Registered
Banned from wife’s 2005 Pilot LX
Joined
·
4,251 Posts
I suggest you re-run the full cold test and report the same parameters you measured in post 17. Perhaps for the hot test take the readings when the cabin is 100 degrees. I’m wondering if the temperature sensors are reporting inaccurate readings and if that is impacting the climate controller.
 
  • Like
Reactions: plplplpl

·
Registered
2004 Honda Pilot
Joined
·
7 Posts
I'm having some issue with my ac and not sure if this is the cause. My ac works but leaking refrigerant constantly. I can recharge it and it will work for a week but then it starts blowing hot air. My wife talks about water dripping in passenger foot well. Also, rear ac does not work. I've used a cheap Chinese transistor which the rear worked but buzz in radio constantly. Would this be the cause or could heater core be bad? Oh dye has been added but nothing on driveway showing leaking outside car.
 
21 - 31 of 31 Posts
Top