Honda Pilot - Honda Pilot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Ok here goes,(just joined,and a one finger typer)my pilot has 345000km on it and still running strong,(sounds like i need to retorque the rocker shaft bridge according to the symptoms)my first transmission lasted 275000km ,bought a used one for 1000cdn i think it had approx 100000km on it . We leave this car out in vancouver,my kids drove it back to Red Deer (12 hours)no issues.After cleaning intake, setting valves,brakes and replacing front end parts,noticed an engine oil leak.Decided to fix myself,(huge job) replaced the oring and the big seal on crank,reinstalled everything,of course refilled with honda trans fluid.Drove for about 1 block got code PO780,rechecked fluid,ok,reset code,flashing D,engine light on again(engine still has a slight oil leak).So took to a transmission shop,told me it was an internal issue,would need to pull trans out.The car still can be moved (has reverse and forward) ,just seems weird that this happened.I guess i got 70000km out of that trans,so probably have to buy another one,at 345000km im not going to dump a pile of cash into.Also,talked with the Honda shop fore,he said these years where known for transmission issues,they tried to fix valve bodies,would last for a week,and would fail again, Anyone out there with any ideas? THANKS!
 

·
Registered
Joined
·
373 Posts
By Eric the car guy.

that code and harsh shifting pretty much mean you need a new transmission, I recommend an aftermarket rebuild over salvage as your likely to end up in the same situation with a salvage yard unit.
 

·
Registered
Joined
·
2,251 Posts
Might want to try the much less expensive (and common solution) route of changing out the 3rd and 4th gear pressure sensors before going full tranny.
 

·
Registered
Joined
·
1,830 Posts
Replace with OEM pressure switches. Someone on this forum tried aftermarket ones and wasted a ton of time swapping parts before ultimately going OEM. Sample size of one, but I’d spend the extra bucks to get the OEM ones.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
just wondering if there is any way to test these pressure sensors, i have calibration equipment (pumps and crystal)OEM sensors and washers 250cdn Thanks!
 

·
Registered
Joined
·
1,830 Posts
I don’t recall seeing any posts where someone has tried to test the sensors.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
talked again with guys at trans shop, they said they did a scan and it is for sure an internal issue,stuck valve in valve body,i asked about the 3rd and 4th sensors,...this shop is good,so probably going to pull trans out and replace,shitty!
 
1 - 9 of 9 Posts
Top