Honda Pilot - Honda Pilot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Just bought a Honda pilot it's been setting since 2016 owner stated it was starting up till last year 2019 now it cranks over and won't start has 241000 miles on it it will start with starting fluid I replaced the relay for the fuel pump and this didn't solve the problem I know it's a fuel issue but where to start any suggestions would be helpful I don't hear the fuel pump buzz or whine when key is turned on the relay and fuel pump fuse is good green key light comes on goes off when you crank car and cut key off the green key blinks several times and goes off but is off while cranking I've been told thease fuel pumps seldome if ever go bad and the only fuel filter is in the tank has anyone had this issue what resolved it I bought this vehicle to fix and drive as it has the 3 rows of seats and we have 5 kids but anyways thanks for all your help I've also herd something about jumping a 601 connector that that may be it but idk where that is or where to even try to do this on a Honda pilot I'm new to Honda's thanks again any ideas where to look would be great
 

·
Registered
Joined
·
26 Posts
Fuel pumps tend to go out when the car has been sitting for a long time. It doesn't matter the car. The fuel eventually corrodes the pump.
 

·
Registered
Joined
·
733 Posts
Age is not on your side on this one. O rings loose their ability to seal with age. You obviously have preasure loss. The pump itself may not be bad. You can perform tests to pinpoint things but I'm replacing it all while I'm in the tank on a vehicle this old.
Did it take several revolutions to start up and just got worse over time, to the point of not starting at all?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Age is not on your side on this one. O rings loose their ability to seal with age. You obviously have preasure loss. The pump itself may not be bad. You can perform tests to pinpoint things but I'm replacing it all while I'm in the tank on a vehicle this old.
Did it take several revolutions to start up and just got worse over time, to the point of not starting at all?
Went from start first couple reveloutions to a no start no warning what guy told me but again I bought it like this I ordered a fuel pump sending unit exc I agree replace it all while I'm there and if it's not it at least it all be new like you said age is not on my side
 

·
Registered
Joined
·
25 Posts
A new fuel pump will probably fix the issue. YouTube has a couple of videos on changing the pump. It will save you hours if you watch the video first. It is not a too hard. Probably a 3 hour job. Before you change the pump, it might be worth trying a can of Seafoam. If you can run the engine long enough to run a tank of gas through it, it might help. Gas that has sat a long while tends to leave a varnish on things and gums things up. Seafoam will dissolve the varnish.
 
1 - 7 of 7 Posts
Top