Honda Pilot - Honda Pilot Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 15 Pilot that has a hard hot start. If I drive to the store go shopping and come out in 20-30min it will crank for 10+ seconds before it starts. Any ideas anyone?
 

·
Registered
Joined
·
9,519 Posts
I have a 15 Pilot that has a hard hot start. If I drive to the store go shopping and come out in 20-30min it will crank for 10+ seconds before it starts. Any ideas anyone?
Do you have a check engine light?
 

·
Registered
Joined
·
9,519 Posts
Just doing some research. Sounds like your fuel pump relay is going bad.
 
  • Like
Reactions: Daltongang

·
Registered
Joined
·
9,519 Posts

·
Super Moderator
2020 Honda Passport Touring AWD Metallic Steel
Joined
·
4,304 Posts
Just doing some research. Sounds like your fuel pump relay is going bad.
If the fuel relay does not fix the problem, you might want change the fuel filter. Not an easy process as it is in the fuel tank itself. I do believe on the 2015 you can get to the pump from the cargo area, instead of having to drop the fuel tank.

You may also want to get a pressure check done on the fuel pump itself, as well as the fuel pressure regulator.
 

·
Registered
Joined
·
2,573 Posts
There was a question tossed out there, was this going on BEFORE you changed your timing belt ? It sounds like your timing is off ..this will cause the issue your experiencing if it is.
 

·
Registered
Joined
·
9,519 Posts
I’ve replaced fuel pump & main ignition relay to no avail that was my first thought.
This was the hope for an easy fix.
What is your current milage?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
This was the hope for an easy fix.
What is your current milage?
950000
There was a question tossed out there, was this going on BEFORE you changed your timing belt ? It sounds like your timing is off ..this will cause the issue your experiencing if it is.
Thank you, it started after the belt was changed not immediately but after. I didn’t do the job myself but I did consider that to be the problem so I took it back for them to recheck it and they said everything lined up. Maybe I’ll just have to take a look myself.
 

·
Registered
Joined
·
2,573 Posts
950000

Thank you, it started after the belt was changed not immediately but after. I didn’t do the job myself but I did consider that to be the problem so I took it back for them to recheck it and they said everything lined up. Maybe I’ll just have to take a look myself.
I had the same situation myself if your able to look at the job yourself that would be great I was told by a shop it was lined up tore into it myself only to discover the rear was off by a almost a full tooth.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #15 ·
I had the same situation myself if your able to look at the job yourself that would be great I was told by a shop it was lined up tore into it myself only to discover the rear was off by a almost a full tooth.
Okay thanks you've helped me make up my mind I'm going to check it myself, very capable, I should have done the job instead of being lazy.
 
1 - 16 of 16 Posts
Top