Honda Pilot - Honda Pilot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 08 honda pilot and recently the front heat/ac only blows warm air. I checked the control valve and cable on the firewall and fod that the cable is connected but not moving when changing the temp controls from cold to hot and back to cold again. Could the cable have come loose on the inside or could it be another problem?
 

·
Registered
Joined
·
5,535 Posts
Gotta love how even though all the knowledgeable folks on the forum know the fix, they've respectfully deferred to me to provide the answer, since I'm the go-to "screw loose" guy around here, it seems. :)


So yeah, tighten that screw.


 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I should've explained that I had already checked that screw. It was tight. Checked under dash. Cable does not move.
 

·
Registered
Joined
·
603 Posts
Can you disconnect the cable at the control valve, and then will the valve move to open and closed?

To inspect the actuator:

 
  • Like
Reactions: plplplpl

·
Registered
Joined
·
4,224 Posts
I have a 08 honda pilot and recently the front heat/ac only blows warm air. I checked the control valve and cable on the firewall and fod that the cable is connected but not moving when changing the temp controls from cold to hot and back to cold again. Could the cable have come loose on the inside or could it be another problem?
In all my experience with this problem, the blend door actuator had to be replaced. Did it start out clicking over and over before it stopped?
134130
 

·
Registered
Joined
·
5,535 Posts
Although first you might want to try just nudging it back into action. Sometimes that's all it takes.

 
1 - 7 of 7 Posts
Top