Honda Pilot - Honda Pilot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
07 Ex 4wd with 120k miles.
Starting a month ago:
1-Purge solinoid valve engine code which was repaired. Also noticed power steering pressure hose has a leak.
2-Blinking D and VSA/! Triangle comes on. Had a friend scan it which came up as a 3rd gear oil pressure switch. Changed trans fluid from Honda and 3rd gear switch from eBay.
3-Reset lights by jumping 4/9 pins and doing VSA memorization. Everything seams ok at that point.
4-Oil and VTM-4 service reminder comes on. Didn’t get a chance to do the service.
5-A week later D starts blinking intermittently. Engine light comes on with codes p0722 and p2135. Trans starts to jerk while shifting.
6-When driving at 55mph a big jerk/jump of gears. VSA/!/VTM-4 lights come on. Speedometer stopped working and engine wouldn’t rev past 2k rpms. Immediately pulled over and turned the engine off. Restarted engine and VSA/!/VTM-4 went off but engine light stayed on. Tried to drive slowly. Speedometer still didn’t work and trans wouldn’t shift. A/T temp light came on. Stopped, put it in P and let it idle until light went off. Reset the engine codes then tried driving starting in 2nd gear. Engine was now able to rev. Seamed to shift when I let off of trottle but A/T Temp light came back on again. Engine lights didn’t come back on. Had it towed to a shop where it’s currently at now.

Has anyone had similar symptoms? I’m really hoping it is only some sensor issue and not a major trans problems. Maybe I damaged the speed sensor wire when changing the 3rd gear switch.

Thank you for reading. Any help is greatly appreciated.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I’m the only owner, got it new in ‘07. So you needed to rebuild 3rd and 4th gear? Or did you changed the oil pressure switches? Do you think using a non genuine 3rd gear oil pressure switch may of caused additional damage?
 
1 - 3 of 3 Posts
Top