Honda Pilot - Honda Pilot Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Recently i changed my water pump along with timing belt and serpentine belt. Triple checked to make sure I set timing right. Did full tune up. Changed battery, put a brand new one. Replaced terminals. I tightened everything up. Re-did some of the wiring. Made sure nothing is exposed, covered everything with shrink sleeves. I have original key and fob. When i went to start it at first it would crank, and it would sound like it was going to start. Until battery died. I charged the battery so many times already in intent to start it. Starter and alternator both tested good. Checked relays and theyre good. At first try battery and green key lights would flash on dash. I got the key light to turn off. Now its just the battery light flashing and car battery dies after trying a couple times to start. Ive been pulling my hair on this one guys. Its been an on going job trying to get my pilot back on the road. Is there any suggestions or idea of what it could be ?
 

·
Registered
Glorificatus Oleum Mutante
Joined
·
12,818 Posts
Have you checked the 3 ground cables/straps?
Battery to frame.
Engine/starter to frame.
Transmission to Frame.
Clean contact points.
Replace if needed.
 

·
Registered
Joined
·
11,218 Posts

·
Registered
Miss our 2005 Pilot
Joined
·
4,549 Posts
Go back and double check every electrical connection that you removed during the maintenance work. Hopefully it’s something as simple as a loose connection.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Have you checked the 3 ground cables/straps?
Battery to frame.
Engine/starter to frame.
Transmission to Frame.
Clean contact points.
Replace if needed.
I just cleaned up the to frame, starter to frame. And thank you for reminding me, i must of forgot the transmission one. Really helpful thanks i appreciate
 
1 - 6 of 6 Posts
Top