Honda Pilot - Honda Pilot Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi all,
04 pilot exl 4wd, 201,530 mileage
So in late December 19 I hit what can only be called a mini sink hole/enormous pot hole here in Pittsburgh. This caused me to pop a cel and vtm lights, was driving fine drove it home and it was pulling misfire codes all over the place. Figured it was plugs so had plugs and coils replaced, still a giant heap of misfire codes running like crap. Popped the top and the egr ports were crammed full, cleaned all that and said screw it and just put a new egr valve and pvc valve on. Still having issues now popping a p1399 so into the dealer we went for a valve adjustment, ran fine for all of 30 miles and back to popping codes and have a slight stutter. The codes I have are a p0301 and a p1399. I am desperate for help at this point, if I can’t get this thing fixed I will be up a creek without a paddle. Any advice would be great and if you know an awesome mechanic in the Pittsburgh area that won’t take me for a ride I would be forever great full
 

·
Registered
Joined
·
6,168 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks! I will for sure check this, the dealer so lovingly did not tighten the clamp after they took it off so I’ll take the whole thing off and give it a once over
 

·
Registered
Joined
·
6,168 Posts
That in itself may be a cause for a vacuum leak. But check anyway and then tighten clamp properly.
 

·
Registered
Joined
·
6,168 Posts
Just a thought, where did you get your spark plugs from?

 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
i got the plugs from advance auto because I needed them right that second otherwise I try to order from rock auto
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
the fuel injectors have not been checked yet, I’m not confident in my ability to do that and not screw it up even more, I’d love to take it back to my regular mechanic but recently his prices have sky rocketed and o can’t keep throwing money away on this
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Just an update, I spoke to a mechanic friend who did his pro thing and it’s the fuel injector in cylinder one dying a slow death. Sucks but is what it is
 

·
Registered
Joined
·
7,037 Posts
Game, set, match: @xGS :)
The "parts cannon" was already loaded and fired at the ignition system with no success.
So, if it's not a spark problem then it must be a fuel problem.
Except in the case of my Pilot, where it was a valve clearance problem.
 

·
Registered
Joined
·
6 Posts
I have the same problem, rough idle and shut down if cold. I change the fuel pump, ignition coil, egr valve, pcv valve, spark plug and intake tube. I got random missfire code again. Pilot 4wd 2008 300km
 

·
Registered
Joined
·
6 Posts
I have the same problem, rough idle and shut down if cold. I change the fuel pump, ignition coil, egr valve, pcv valve, spark plug and intake tube. I got random missfire code again. Pilot 4wd 2008 300km
I change the timing belt and water pump too. Clean all intake.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #14
I change the timing belt and water pump too. Clean all intake.
Did you have the valve clearance adjustment done? All of my exhaust were tight and my intake loose. Also mike isn’t having much of a rough idle it’s just sputtering a bit and annoying me
 

·
Registered
Joined
·
53 Posts
Just an update, I spoke to a mechanic friend who did his pro thing and it’s the fuel injector in cylinder one dying a slow death. Sucks but is what it is
to properly test injectors they must be removed and put in a injector tester or listen to each one with stethoscope if they cannot be removed, as for your sputtering issue i would go and get a fuel pressure test, if your confidant you can accomplish, not to much of a difficult task and buying the gauge is far less cheaper than paying someone... i would say check the fuel filter but its in the tank thats why i suggest the fuel pressure test...
 
1 - 15 of 15 Posts
Top