2013 EX-L Audio/Info Screen Blank - Honda Pilot - Honda Pilot Forums

Register Home Forums Active Topics Insurance Photo Gallery Garage Search Today's Posts Mark Forums Read Auto Escrow
Piloteers.org is the premier Honda Pilot Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 08-01-2013, 04:36 PM   #1 (permalink)
Registered User
 
Join Date: Jul 2013
Location: NY
Posts: 3
Feedback Score: 0 reviews
Default 2013 EX-L Audio/Info Screen Blank

Today, my 17 day old 2013 EX-L (No Nav) Audio/Information Screen went blank......just all black. Radio operates, but no display. Back-up camera does not display. Can't get Service appointment for 6 days! Has anyone had this problem? Maybe an easy fix......I hope/wish.
mdsulli is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-01-2013, 05:35 PM   #2 (permalink)
DMG
Registered User
 
DMG's Avatar
 
Join Date: Aug 2012
Location: Mill Creek, WA
Posts: 823
Feedback Score: 0 reviews
Default

Sorry for your inconvenience with no display.

The only easy fix was yesterday or maybe in 6 days when you can bring it in for dealer for replacement.
__________________

Please remember this is my opinion and opinions are like a$$ holes...... everyone has one and they all stink.
DMG is online now   Reply With Quote
Old 08-02-2013, 07:54 AM   #3 (permalink)
Registered User
 
Join Date: Jul 2013
Location: Central, NJ
Posts: 30
Feedback Score: 0 reviews
Default

The only thing I can think of is may be a fuse blowing up. Check the manual to see if there is a fuse diagram for the display first though!
blanchimont is offline   Reply With Quote
Old 08-02-2013, 10:33 AM   #4 (permalink)
Registered User
 
Go Steelers's Avatar
 
Join Date: Jan 2008
Location: Central Ohio
Posts: 266
Feedback Score: 0 reviews
Default

Possibly the wiring harness to the display came unplugged?
__________________
2014 Civic Si - Crystal Black Pearl
2012 4WD Pilot EXL-RES - Polished Metal
2009 Odyssey EXL-RES - Bali Blue
2011 Mazda3i Touring - White
Former Hondas - 2008 Pilot EXL-RES - Formal Black, 2003 Odyssey EXL-RES - Redrock, 2002 Accord EXL - Nighthawk Black, 1994 Accord EX, 1990 Acura Integra, 1986 Accord, 1981 Accord
Go Steelers is offline   Reply With Quote
Old 08-07-2013, 10:16 PM   #5 (permalink)
Registered User
 
Join Date: Jul 2013
Location: NY
Posts: 3
Feedback Score: 0 reviews
Default Problem Resolved - No Defect Found

Today Honda Service removed screen, found nothing, reinstalled and now Audio/Info Screen working fine. Perhaps a loose connection per Honda Service. I assume all connections are "captive" connectors, so really do not come loose. I'll remain positive and hope this is the fix.
mdsulli is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:05 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright 2000 piloteers.org. All Rights Reserved.